Volvo Community Forum. The Forums of the Volvo Owners Club

Forum Rules Volvo Owners Club About VOC Volvo Gallery Links Volvo History Volvo Press
Go Back   Volvo Owners Club Forum > "Technical Topics" > XC90 '02'15 General
Register Members CarsBlogs Help Calendar Mark Forums Read

Notices

XC90 '02'15 General Forum for the Volvo XC90 Phase 1 Series

Information
  • VOC Members: There is no login facility using your VOC membership number or the details from page 3 of the club magazine. You need to register in the normal way
  • AOL Customers: Make sure you check the 'Remember me' check box otherwise the AOL system may log you out during the session. This is a known issue with AOL.
  • AOL, Yahoo and Plus.net users. Forum owners such as us are finding that AOL, Yahoo and Plus.net are blocking a lot of email generated from forums. This may mean your registration activation and other emails will not get to you, or they may appear in your spam mailbox

Thread Informations

Help fault code ECM 6805

Views : 9371

Replies : 15

Users Viewing This Thread :  

Reply
 
Thread Tools Display Modes
Old Aug 22nd, 2011, 18:18   #1
davew993
New Member
 

Last Online: Sep 26th, 2011 08:50
Join Date: May 2007
Location: Billericay
Default Help fault code ECM 6805

Hi can anyone help me. I have a 2005 D5 163ps xc90.

i am getting a fault with my car that sometimes when i tow a caravan up a hill and the cars speed slows to 54 mph the car kicks down and puts Engine service light on and goes into limp mode. i keep throttle in same position and after 30 sec to 1 min it clears fault and light goes off dash and it back to normal!!

i have changed rear engine pad, hoses to pads and sensors, govenor on front of head and sensor on air cleaner box that pipes go to and it still does it but only when towing.

each time it does it fault code ECM 6895 - boost pressure control intermitant fault is logged.

i am pulling what hair i have left out now lol

can anyone point me in direction of what poss could be wrong please.

thanks
Dave
davew993 is offline   Reply With Quote
Old Aug 22nd, 2011, 18:30   #2
GJB
Premier Member
 

Last Online: Yesterday 22:58
Join Date: Dec 2004
Location: Cromer Norfolk
Thumbs up

Try the fuel filter seems to come up quite often
GJB is offline   Reply With Quote
Old Aug 22nd, 2011, 18:39   #3
davew993
New Member
 

Last Online: Sep 26th, 2011 08:50
Join Date: May 2007
Location: Billericay
Default

Hi thanks for reply.

Did think about fuel filter but thought that would do it all the time not just when towing plus thought that might put up fuel pressure fault code not boost pressure!!

think i will try it though as it seems to be common issue.
davew993 is offline   Reply With Quote
Old Aug 22nd, 2011, 18:44   #4
outnumbered
Lunatic from Wakefield
 
outnumbered's Avatar
 

Last Online: Yesterday 21:13
Join Date: Dec 2004
Location: wakefield
Default

the list is not endless and there is light at the end of the tunnel.
check the following.
engine pads both front and rear blockl them off.
pipe to turbo from air box can close when under load if its soft it will proberbly need a new one.
intercooler is it split at the bottom.
what is your driving style like it could be the the vnt is sticking on the turbo to check this use a mittivac..
do a search on that code and you will find some interesting reading and fixes .
hope that helps.
http://www.volvoforums.org.uk/showth...hlight=ecm6805
mike
__________________
XC 70 D5 SE Silver 2007 185Bhp Bailey Pageant Limousin Series 7 @ 1700 kg @ 96%
V70 D5 SE Blackcurrant Pearl 2007 185Bhp

Last edited by outnumbered; Aug 22nd, 2011 at 18:47.
outnumbered is offline   Reply With Quote
Old Aug 22nd, 2011, 19:08   #5
davew993
New Member
 

Last Online: Sep 26th, 2011 08:50
Join Date: May 2007
Location: Billericay
Default

Thanks for your reply an link. I read your post on the link and it way over my head but i will show it to the guy who works on my car.

The air pipe to turbo do you mean the small one down back of engine or the one that fits onto air box then onto silver metal pipe?
davew993 is offline   Reply With Quote
Old Aug 23rd, 2011, 20:01   #6
Genghis
Genghis
 

Last Online: May 12th, 2013 20:05
Join Date: May 2006
Location: Surrey
Default

Dave - sounds like you have the same issue a few of us have. See the Engine service light appears thread
Genghis is offline   Reply With Quote
Old Aug 23rd, 2011, 20:15   #7
davew993
New Member
 

Last Online: Sep 26th, 2011 08:50
Join Date: May 2007
Location: Billericay
Default

Hi All,

I tried to contact Volvo UK tech help today regarding this issue a few of us are having but didnt get anywhere. Just got told take to Volvo dealer and they will contact tech support if needed.

I will be changing fuel filter tom and then testing next week towing caravan. I will then report if this cures problem for me or not.

If that does not cure fault i will then try replacing air intake pipes.

That will only then leave turbo and vac pump!!!

Oh what joy lol
davew993 is offline   Reply With Quote
Old Aug 23rd, 2011, 20:22   #8
outnumbered
Lunatic from Wakefield
 
outnumbered's Avatar
 

Last Online: Yesterday 21:13
Join Date: Dec 2004
Location: wakefield
Default

you can test the vnt by using a mitty vac to see if the arm moves smoothly on the turbo and is not sticking. to check whats coming from the vac pump.
http://www.volvoforums.org.uk/showthread.php?t=131487
mike
__________________
XC 70 D5 SE Silver 2007 185Bhp Bailey Pageant Limousin Series 7 @ 1700 kg @ 96%
V70 D5 SE Blackcurrant Pearl 2007 185Bhp
outnumbered is offline   Reply With Quote
Old Aug 24th, 2011, 08:10   #9
Genghis
Genghis
 

Last Online: May 12th, 2013 20:05
Join Date: May 2006
Location: Surrey
Default

Dave - if you see the other thread about Engine service light a few of us on there have the same problems. The garage I used already have been in contact with Volvo tech support but to no avail I'm afraid
Genghis is offline   Reply With Quote
Old Sep 26th, 2011, 08:49   #10
davew993
New Member
 

Last Online: Sep 26th, 2011 08:50
Join Date: May 2007
Location: Billericay
Default

Hi all,

Fuel filter changed and it made a massive improvment to the drive of the car. The old one was very black when removed so dont think it had been changed for a while.

Car still did fault code once when towing so now changing Air intake hose this week.

Will let you know if hose fix fault.
davew993 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 01:42.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.