Volvo Community Forum. The Forums of the Volvo Owners Club

Forum Rules Volvo Owners Club About VOC Volvo Gallery Links Volvo History Volvo Press
Go Back   Volvo Owners Club Forum > Blogs > BrianH
Register Members CarsBlogs Help Calendar Mark Forums Read

Notices

Information
  • VOC Members: There is no login facility using your VOC membership number or the details from page 3 of the club magazine. You need to register in the normal way
  • AOL Customers: Make sure you check the 'Remember me' check box otherwise the AOL system may log you out during the session. This is a known issue with AOL.
  • AOL, Yahoo and Plus.net users. Forum owners such as us are finding that AOL, Yahoo and Plus.net are blocking a lot of email generated from forums. This may mean your registration activation and other emails will not get to you, or they may appear in your spam mailbox

Rate this Entry

Tyres

Posted Apr 22nd, 2019 at 12:38 by BrianH

As I cant find Michelin tyres any more, on recommendation went to Bridgestone, but I've had balance problems ever since. Anything over 67mph and I feel it through the steering.


I got the tyres checked out for roundness, then replaced the bottom ball joints, track rod ends. sway bar rubbers, and the rack has been refurbished recently. Still going off at 67mph!!

Now the centre bearing and the big rubber support and seal (a replacement couldn't be found last time). Prop. rebalanced.

Well it is better but not as I remembered it. lovely and stable at speed.


Next is to back to front swop and rebalance.

It couldn't be the Bridgestone's could it?? I have swopped the spare Michelin to both fronts with no joy. Onward and upward.


BrianH
Posted in Uncategorized
Views 905 Comments 0
« Prev     Main     Next »
Total Comments 0

Comments

 

All times are GMT +1. The time now is 12:57.


Powered by vBulletin
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.