Volvo Community Forum. The Forums of the Volvo Owners Club

Forum Rules Volvo Owners Club About VOC Volvo Gallery Links Volvo History Volvo Press
Go Back   Volvo Owners Club Forum > Blogs > JohnXC90V8
Register Members CarsBlogs Help Calendar Mark Forums Read

Notices

Information
  • VOC Members: There is no login facility using your VOC membership number or the details from page 3 of the club magazine. You need to register in the normal way
  • AOL Customers: Make sure you check the 'Remember me' check box otherwise the AOL system may log you out during the session. This is a known issue with AOL.
  • AOL, Yahoo and Plus.net users. Forum owners such as us are finding that AOL, Yahoo and Plus.net are blocking a lot of email generated from forums. This may mean your registration activation and other emails will not get to you, or they may appear in your spam mailbox

Rate this Entry

Navigation Screen Problem

Posted Dec 7th, 2011 at 19:20 by JohnXC90V8

I have a 2005 xc90 with built in navigation.
The system is working because it talks to me after hitting buttons on steering wheel or remote, however, the screen doesn't rise up out of the dashboard.
I plan to remove the unit this weekend and look for obvious mechanical problems like a sticking motor or broken gear.
Does anyone have advice for me on what to check for?
Thanks for your advice,
John
Posted in Uncategorized
Views 4433 Comments 3
« Prev     Main     Next »
Total Comments 3

Comments

  1. Old Comment
    Took the unit out, manually raised the screen and reconnected the wires, still nothing. The screen wont even go down after turning the car off.
    I removed one of the circuit boards and found corrosion on some components and 3 out of 4 ribbon wire connectors also had corrosion.
    Tried cleaning the ribbon wires and board and tried it again but still nothing.
    Maybe the board it too damaged???
    I'm looking for a used complete display unit to swap with mine to see if that is the problem.
    Posted Dec 12th, 2011 at 21:05 by JohnXC90V8 JohnXC90V8 is offline
  2. Old Comment
    Checked all fuses and they are good.
    Checked the 5-pin connector going to the unit and a few of the pins measured 12v, so I guess that's not the issue eiter.
    Found a working used unit on Ebay that is identical to mine so when it comes in, I'll try swapping units.
    Posted Dec 13th, 2011 at 15:58 by JohnXC90V8 JohnXC90V8 is offline
  3. Old Comment
    Swapped the unit today and the whole navigation system worked fine. I'm no expert but from the look of that one circuit board that was on my original unit, I'd say that was the problem. Why doesn't Volvo recognize the fact that most of the circuit boards in these vehicles should be coated to prevent corrosion and many ghost electrical problems we spend tons of money trying to track down and repair???
    Posted Dec 24th, 2011 at 15:22 by JohnXC90V8 JohnXC90V8 is offline
 

All times are GMT +1. The time now is 22:44.


Powered by vBulletin
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.