Volvo Owners Club Forum

Volvo Owners Club Forum (https://www.volvoforums.org.uk/index.php)
-   XC90 '02'15 General (https://www.volvoforums.org.uk/forumdisplay.php?f=37)
-   -   XC90 - Engine System Service Required (https://www.volvoforums.org.uk/showthread.php?t=238825)

Spike H Oct 27th, 2015 09:40

XC90 - Engine System Service Required
 
Hi,

First post, so here goes!

I have a 61 plate D5 Exec XC90. With 23,000 miles. First 3 services were carried out at Volvo main dealership.

I recently moved to the IOW and as there is no Volvo dealer went to an independent for its 4th service.

A few days after the service a message came up: Engine System Service Required.

I went back to the garage and the mechanic tried to reset it by pushing in the trip button whilst turning the key. During this time code 042 was displayed. The message reset but kept reappearing on starting the engine.

He went away and came back with a box of tricks that he plugged in under the dash and reset it.

Fast forward 1 week and the same message has reappeared. Probably at the same location as the first time i.e. going up a nearby hill.

Whilst trying to reset using the trip/key trick, code 082 was displayed. Message reappeared on starting the engine.

Did some research and it appears that the oil may have been overfilled and it does look a little high on the dipstick. (Correlates with the hill).

I intend to remove some oil using a syringe kit when it arrives. Questions I have:

a. If it is overfilled oil, will the fault message reset itself after rectifying or does it need to go back to the garage?

b. Where do I find out what the codes mentioned above mean?

Any other information gratefully received. Many thanks.

rsymes2k Oct 27th, 2015 10:13

Quote:

Originally Posted by Spike H (Post 2000916)
Hi,

First post, so here goes!

I have a 61 plate D5 Exec XC90. With 23,000 miles. First 3 services were carried out at Volvo main dealership.

I recently moved to the IOW and as there is no Volvo dealer went to an independent for its 4th service.

A few days after the service a message came up: Engine System Service Required.

I went back to the garage and the mechanic tried to reset it by pushing in the trip button whilst turning the key. During this time code 042 was displayed. The message reset but kept reappearing on starting the engine.

He went away and came back with a box of tricks that he plugged in under the dash and reset it.

Fast forward 1 week and the same message has reappeared. Probably at the same location as the first time i.e. going up a nearby hill.

Whilst trying to reset using the trip/key trick, code 082 was displayed. Message reappeared on starting the engine.

Did some research and it appears that the oil may have been overfilled and it does look a little high on the dipstick. (Correlates with the hill).

I intend to remove some oil using a syringe kit when it arrives. Questions I have:

a. If it is overfilled oil, will the fault message reset itself after rectifying or does it need to go back to the garage?

b. Where do I find out what the codes mentioned above mean?

Any other information gratefully received. Many thanks.

I could be wrong but overfilling with oil may have killed a lambda sensor...

Take it back to the garage, they overfilled it, they potentially caused the issue...

Horton Nov 1st, 2015 12:15

Definitely overfilled with oil!! There is a sensor in the sump which uses sonar to detect the oil level. It's VERY sensitive, and even if you fill the correct 5.7 litres it will often put the EML light on. The level should be set using Vida or something similar and the engine needs to be run to temperature, with the level being set between 70 and 80 percent.

ifzal123 Nov 1st, 2015 14:04

Definitely oil related.

As already said they sensor is very sensitive and you should only fill the oil up 2/3rds on the dip stick.


See thread below

http://www.volvoforums.org.uk/showthread.php?t=127474

Spike H Nov 1st, 2015 16:25

1 Attachment(s)
Thank you for your replies.

I've sucked about 500ml of oil out through the dipstick pipe using a large syringe and small bore plastic tubing.

The oil level is now roughly what it should be according to the tally. (Photo attached).

Does anybody have any idea how to remove the 'Engine System Service' message?

I've tried to remove it doing the trip/key method to no avail. The first time it was reset (before oil removed) the mechanic had to use a device plugged in under the dash.

Could be a trip back to the indie dealer if all else fails.

Thanks again.

cheshired5 Nov 1st, 2015 17:41

Most error message disappear on their own once the fault is fixed and the system has checked itself a few times so taking the car for a drive and patience usually works. :thumbs_up:

Of course it's always preferable to know exactly what the code was rather than guessing.

Keith T Nov 26th, 2015 10:43

XC90 Engine Systen Service Required
 
First post - just joined.

56 plate D5 80,000 miles. 100 miles after service. Engine etc warning message.

2 faults
6665 glow plug relay control faulty signal
5660 oil level sensor faulty signal

Both cleared by local garage for 20 inc VAT.

I was expecting the swirl valve cable fault (as in another Engine System Service Required three (that I could not find this morning - apologies). But the cable was fine.

cheshired5 Nov 26th, 2015 11:46

Quote:

Originally Posted by Keith T (Post 2017441)
First post - just joined.

56 plate D5 80,000 miles. 100 miles after service. Engine etc warning message.

2 faults
6665 glow plug relay control faulty signal
5660 oil level sensor faulty signal

Both cleared by local garage for 20 inc VAT.

That's not how code clearing works.
If the problem isn't fixed, the codes and warning will return.

Spike H Nov 27th, 2015 09:43

Quote:

Originally Posted by cheshired5 (Post 2003750)
Most error message disappear on their own once the fault is fixed and the system has checked itself a few times so taking the car for a drive and patience usually works. :thumbs_up:

Of course it's always preferable to know exactly what the code was rather than guessing.

After much research I'm fairly certain the cause of the 'Engine System Service Required' message has been resolved i.e. oil overfill by the Indie garage.

However, the message remains, although admittedly I haven't driven the car that much.

I just need a cheapie reader to clear the message, I'm not interested at this stage in the more expensive readers.

Any recommends please? Thanks for your help.

cheshired5 Nov 27th, 2015 11:28

Quote:

Originally Posted by Spike H (Post 2017861)
However, the message remains, although admittedly I haven't driven the car that much.

Drive it some more then.
The message will go on its own if oil was the problem and you've resolved it.


All times are GMT +1. The time now is 03:29.

Powered by vBulletin
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.