Volvo Owners Club Forum

Volvo Owners Club Forum (https://www.volvoforums.org.uk/index.php)
-   XC90 '02Ė'15 General (https://www.volvoforums.org.uk/forumdisplay.php?f=37)
-   -   Xc90 2.4 d5 failing to start but cranks (https://www.volvoforums.org.uk/showthread.php?t=311059)

Kennywillis77 Oct 21st, 2020 06:55

Xc90 2.4 d5 failing to start but cranks
 
1 Attachment(s)
So my xc90 is failing to start, it stated when I broke down the aa came out and said that the high pressure fuel pump was knackered so replaced with a second hand one that was tested its 185bhp

The issue is its got all these errors and I have replaced a lot of sensors with no avail any help would be amazing

I tested with multiple diagnostic software Vida and launch

reggit Oct 21st, 2020 07:39

Itís looking like a fuel pressure problem there. What codes did Vida report, theyíll be more specific.
Iíd be tempted to look at the fuel filter first and with that off check to see if the low pressure pump is working.

mosesalobo Oct 23rd, 2020 06:30

Quote:

Originally Posted by Kennywillis77 (Post 2674793)
So my xc90 is failing to start, it stated when I broke down the aa came out and said that the high pressure fuel pump was knackered so replaced with a second hand one that was tested its 185bhp

The issue is its got all these errors and I have replaced a lot of sensors with no avail any help would be amazing

I tested with multiple diagnostic software Vida and launch

Hi all, Would be nice to hear what the solution to this issue could be as I have the same problem. Redone engine and now cannot get the car to start. Replaced fuel pump in fuel tank after we confirmed the previous one was knackered. Also had to check the flywheel /crankshaft sensor - replaced it.

Tyler350z Oct 23rd, 2020 12:12

Any update on this? I have a similar problem... started fine before I changed fuel pump and swirl flaps but now wonít start?
Any suggestions
Thanks
Tyler

Fika Oct 23rd, 2020 19:21

When you replace the fuel pump don't you typically need to bleed the air or turn on fuel pump via key (but not crank the car- that humming sound I hear from the car for a brief moment just before I crank the engine I think is the fuel pump pressurising/working) so that fuel is making it past the fuel pump and into the fuel rails?

Tyler350z Oct 24th, 2020 13:17

I have had the car tested via diagnostic laptop, showing full pressure to the rail, no error codes coming through at all the thing just wonít start!
Close to being done with it now if I donít find a solution soon lol

reggit Oct 24th, 2020 18:59

Quote:

Originally Posted by Tyler350z (Post 2675579)
I have had the car tested via diagnostic laptop, showing full pressure to the rail, no error codes coming through at all the thing just wonít start!
Close to being done with it now if I donít find a solution soon lol

Blow a bit of easystart up the air intake, if it fires on that (it will sound horrible), youíre looking at a fuel system problem. If not, itís intake related.

hodge911 Oct 24th, 2020 19:15

This might help
https://youtu.be/pcWGTAAF1vY

Tyler350z Oct 25th, 2020 16:07

Thanks for the help guys, still no luck, there is no mechanical reason as such (I think) as to why it isnít starting,
Decided to start looking at glow plugs and fuses now...
Unless anyone has anymore suggestions
Cheers
Tyler

Harley Dave Oct 25th, 2020 17:48

Diesels are compression-ignition engines

If there's fuel, squirted in at the right time, and compression and the engine turns, it should run.

Glow plugs are to help cold starts - shouldn't be necessary in UK yet.

Have you tried the previously suggested squirt of easy start, as this will prove you have compression?

Sounds like something is inhibiting the actual squirt of fuel by the injectors - but I'm out of my knowledge depth after that.

Cheers

Dave


All times are GMT +1. The time now is 03:03.

Powered by vBulletin
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.