Volvo Community Forum. The Forums of the Volvo Owners Club

Forum Rules Volvo Owners Club About VOC Volvo Gallery Links Volvo History Volvo Press
Go Back   Volvo Owners Club Forum > "Technical Topics" > S80 '98-'06 / S60 '00-'09 / V70 & XC70 '00-'07 General

Notices

S80 '98-'06 / S60 '00-'09 / V70 & XC70 '00-'07 General Forum for the S80 '98-'06 / S60 '00-'09 / V70 & XC70 '00-'07 models

Information
  • VOC Members: There is no login facility using your VOC membership number or the details from page 3 of the club magazine. You need to register in the normal way
  • AOL Customers: Make sure you check the 'Remember me' check box otherwise the AOL system may log you out during the session. This is a known issue with AOL.
  • AOL, Yahoo and Plus.net users. Forum owners such as us are finding that AOL, Yahoo and Plus.net are blocking a lot of email generated from forums. This may mean your registration activation and other emails will not get to you, or they may appear in your spam mailbox

Thread Informations

2005 XC70 SRS reset. No communication to many modules

Views : 102

Replies : 7

Users Viewing This Thread :  

Reply
 
Thread Tools Display Modes
Old Jan 14th, 2021, 11:29   #1
tonygee
New Member
 

Last Online: Jan 24th, 2021 16:53
Join Date: Jun 2018
Location: Fife, Scotland
Default 2005 XC70 SRS reset. No communication to many modules

Hoping someone can help.

I've a 2005 model year XC70. I have a Vida Dice clone. I did the classic disconnecting the AC panel without disconnecting the battery and triggered the SRS light and SRS service urgent message.

Thought I could easily reset it with the Dice, but I cannot communicate with the SRS module, or many other modules, see photos. No fault codes are stored, presumably because Dice cannot access the modules.

I've checked the CEM connections externally for any signs of water ingress, but they're perfectly clean and there is no evidence of water ingress.

I have the DIM out at the moment, and it's the later model with surface mount LEDs etc, which I thought was relatively trouble free.

Any advice on where I should be looking? Thanks in advance.
Attached Images
File Type: jpg IMG_20210112_161007934__1610619915_14170.jpg (185.8 KB, 6 views)
File Type: jpg IMG_20210112_160817652__1610619780_97566.jpg (196.3 KB, 10 views)
tonygee is offline   Reply With Quote
Old Jan 14th, 2021, 11:35   #2
cheshired5
Premier Member
 

Last Online: Jan 23rd, 2021 17:03
Join Date: Dec 2013
Location: Crewe
Default

Looks like you have a dead Dice.
Has it ever successfully connected?
__________________
2002 S60 SE D5 Manual
205000 miles
cheshired5 is offline   Reply With Quote
Old Jan 14th, 2021, 11:43   #3
tonygee
New Member
 

Last Online: Jan 24th, 2021 16:53
Join Date: Jun 2018
Location: Fife, Scotland
Default

Thanks for the quick reply. It has connected to some modules and cleared codes, but never to those modules in red.
tonygee is offline   Reply With Quote
Old Jan 14th, 2021, 11:57   #4
cheshired5
Premier Member
 

Last Online: Jan 23rd, 2021 17:03
Join Date: Dec 2013
Location: Crewe
Default

The Dice is knackered unfortunately.
Communication to all available modules is one of the many things I test on Dice and VCX before selling them and if they have a sea of red blocks like in your pictures, they get sent back.

If you check various Parameters from the affected modules in the Vehicle Communication section, you'll find inconsistent or no data from them.

You can check the Dice and confirm its operation on an alternative known working Volvo model but I think you're going to have exactly the same outcome.
__________________
2002 S60 SE D5 Manual
205000 miles
cheshired5 is offline   Reply With Quote
Old Jan 14th, 2021, 12:17   #5
tonygee
New Member
 

Last Online: Jan 24th, 2021 16:53
Join Date: Jun 2018
Location: Fife, Scotland
Default

Thanks again Simon. Could you PM me the current price and your payment details for a replacement Dice please.
tonygee is offline   Reply With Quote
Old Jan 14th, 2021, 13:03   #6
cheshired5
Premier Member
 

Last Online: Jan 23rd, 2021 17:03
Join Date: Dec 2013
Location: Crewe
Default

Pm sent.
Just a quick question though.
Have you had Dice and Vida connected with the above problems when the DIM and everything else is plugged in or have you only read the car with the DIM removed?
__________________
2002 S60 SE D5 Manual
205000 miles
cheshired5 is offline   Reply With Quote
Old Jan 14th, 2021, 13:31   #7
tonygee
New Member
 

Last Online: Jan 24th, 2021 16:53
Join Date: Jun 2018
Location: Fife, Scotland
Default

Yes, these scans were carried out with everything intact. Have only just removed the DIM to inspect it.
tonygee is offline   Reply With Quote
Old Jan 14th, 2021, 13:51   #8
cheshired5
Premier Member
 

Last Online: Jan 23rd, 2021 17:03
Join Date: Dec 2013
Location: Crewe
Default

Ok. It was just a thought as the DIM is not just a speedo and is interconnected to a surprisingly number of other modules.

All of the red network errors on a fully connected system still point to a faulty Dice then.
__________________
2002 S60 SE D5 Manual
205000 miles
cheshired5 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 11:42.


Powered by vBulletin
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.