Volvo Community Forum. The Forums of the Volvo Owners Club

Forum Rules Volvo Owners Club About VOC Volvo Gallery Links Volvo History Volvo Press
Go Back   Volvo Owners Club Forum > "General Topics" > General Volvo and Motoring Discussions
Register Members CarsBlogs Help Calendar Mark Forums Read

Notices

General Volvo and Motoring Discussions This forum is for messages of a general nature about Volvos that are not covered by other forums and other motoring related matters of interest. Users will need to register to post/reply.

Information
  • VOC Members: There is no login facility using your VOC membership number or the details from page 3 of the club magazine. You need to register in the normal way
  • AOL Customers: Make sure you check the 'Remember me' check box otherwise the AOL system may log you out during the session. This is a known issue with AOL.
  • AOL, Yahoo and Plus.net users. Forum owners such as us are finding that AOL, Yahoo and Plus.net are blocking a lot of email generated from forums. This may mean your registration activation and other emails will not get to you, or they may appear in your spam mailbox

Thread Informations

XC90 - post service problems

Views : 103

Replies : 1

Users Viewing This Thread :  

Reply
 
Thread Tools Display Modes
Old Jul 12th, 2019, 10:54   #1
Fernet
New Member
 

Last Online: Jul 12th, 2019 10:55
Join Date: Jul 2019
Location: Hastings
Default XC90 - post service problems

Hi, I bought an 05 XC90 about a month ago. When I bought it it had messages saying engine service required and intermittently alarm system service required. Within a week the reverse beepers stopped working and another message had come up saying parking assist service required. I sent it for a service yesterday (not at a Volvo dealership) and they havent addressed the parking assist issue despite agreeing to - so Im waiting for a call back) however upon their return of the vehicle a new message has come up saying transmission service required. Is this coincidental or has something theyve done caused this to come up? Im now nervous to drive the car in case its telling me the gearbox has failed or something serious.
Fernet is offline   Reply With Quote
Old Jul 12th, 2019, 14:12   #2
simonjedrake
Premier Member
 

Last Online: Yesterday 23:52
Join Date: May 2007
Location: Shrewsbury
Default

This sounds like an electrical issue:
1. Is the battery the original as Volvo Batteries have a life expectance of between 10 to 12 years?
If it's the original, pop to your local Volvo dealer who are able to supply genuine OEM batteries at very competitive costs.
2. If the Battery is relatively new & charged, then suggest you try a Sensus Reboot. Just disconnect the -ve terminal on the Battery in the Boot ONLY, then go and make a cuppa and wait 10 mins to allow all the cars electronics to totally deactivate. - then reconnect.
3. If still no joy, then repost an updated question in the below forum specific to your model.
https://www.volvoforums.org.uk/forumdisplay.php?f=37

Hope this helps you.
__________________
XC60 T5 AWD Inscription Pro (MY19). Electric Silver. Xenium & Intellisafe Packs, HUD, HK Sound, Heated Rear Seats, 4 Zone Climate, Towbar, Exterior Styling Kit, Apple CarPlay, Polestar.
Previous - 850 T5, V70 T5, XC60 D5 AWD MY13 & MY16
simonjedrake is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 09:57.


Powered by vBulletin
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.