Volvo Community Forum. The Forums of the Volvo Owners Club

Forum Rules Volvo Owners Club About VOC Volvo Gallery Links Volvo History Volvo Press
Go Back   Volvo Owners Club Forum > "Technical Topics" > Diesel Engines

Notices

Diesel Engines A forum dedicated to diesel engines fitted to Volvo cars. See the first post in this forum for a list of the diesel engines.

Information
  • VOC Members: There is no login facility using your VOC membership number or the details from page 3 of the club magazine. You need to register in the normal way
  • AOL Customers: Make sure you check the 'Remember me' check box otherwise the AOL system may log you out during the session. This is a known issue with AOL.
  • AOL, Yahoo and Plus.net users. Forum owners such as us are finding that AOL, Yahoo and Plus.net are blocking a lot of email generated from forums. This may mean your registration activation and other emails will not get to you, or they may appear in your spam mailbox

Thread Informations

No singal to injectors

Views : 247

Replies : 5

Users Viewing This Thread :  

Reply
 
Thread Tools Display Modes
Old Jun 6th, 2021, 19:18   #1
venomtail
Junior Member
 

Last Online: Jun 19th, 2021 22:37
Join Date: Oct 2019
Location: Lincoln
Post No singal to injectors

Can't start the engine on my S80 after putting the injectors back in, as well as the cover to get access to the swirl flaps. At first I thought I might need to bleed the engine of air in the fuel systems, prime it but checking some more there seems to be nothing coming the injectors. Nothing coming from the noid lights confirm this.

Anyone know what the most likely issue is and where to look? Looking around most people say either ECU or wiring. Is there a best way to test myself if these are the ones not working?

Fixes even if one of these are faulty? Could battery be too low so the signal is prevented from being passed? What's an ECU replacement like? Is there some sort of reprogramming needed and if yes, why?
venomtail is offline   Reply With Quote
Old Jun 9th, 2021, 21:31   #2
Black dog
Member
 

Last Online: Jun 19th, 2021 00:04
Join Date: Jul 2016
Location: Derry
Default

I'm guessing theirs no signal because there's no fuel pressure likely due to having bol locksed the injectors messing with them on the bench chasing your tail with a problem you were advised has nothing to do with injectors.
Il advise one more time, your issue started after breaking a cam belt and the cam lobes turning on the shaft would be the best place to look for the cause of your issues.
__________________
If I've offended you, good! That was my intention
Black dog is offline   Reply With Quote
Old Jun 9th, 2021, 21:48   #3
venomtail
Junior Member
 

Last Online: Jun 19th, 2021 22:37
Join Date: Oct 2019
Location: Lincoln
Default

Quote:
Originally Posted by Black dog View Post
Il advise one more time, your issue started after breaking a cam belt and the cam lobes turning on the shaft would be the best place to look for the cause of your issues.
The issues started after a "diagnostics" at the Volvo dealership where I got a car back that had no power and by the sound of it, a cylinder that was shut off. The belt had snapped months before, was replaced, verified and car was fully functional and fully drivable. Just barely noticable lack of power that was moslty due to the Soot filter being full, so the car reduced its power.

Even after being verified by a Volvo mechanic, the dealership also verified that timings are all in order and nothing seems wrong.

But anything goes, will also check your suggestions.
venomtail is offline   Reply With Quote
Old Jun 9th, 2021, 23:12   #4
Black dog
Member
 

Last Online: Jun 19th, 2021 00:04
Join Date: Jul 2016
Location: Derry
Default

It wasn't my suggestion someone else on your thread suggested it. But it was my suspicion from the start. It needs looking at before you go further. It's been poked and probed over so many times according to your thread, but from what I read nobody has had the balls to remove the cam cover and actually look.
__________________
If I've offended you, good! That was my intention
Black dog is offline   Reply With Quote
Old Jun 10th, 2021, 13:23   #5
Simmy
Premier Member
 
Simmy's Avatar
 

Last Online: Yesterday 18:50
Join Date: Mar 2017
Location: Manchester
Default

if its had a snapped cam belt its not unuseual for it to split or break the cam holding caps needs investigateing
Simmy is offline   Reply With Quote
Old Jun 10th, 2021, 13:48   #6
cheshired5
Premier Member
 

Last Online: Yesterday 19:50
Join Date: Dec 2013
Location: Crewe
Default

What is the rail pressure during cranking?
__________________
2002 S60 SE D5 Manual
208000 miles
cheshired5 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 05:16.


Powered by vBulletin
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.