Volvo Community Forum. The Forums of the Volvo Owners Club

Forum Rules Volvo Owners Club About VOC Volvo Gallery Links Volvo History Volvo Press
Go Back   Volvo Owners Club Forum > "Technical Topics" > S80 '06> / V70 '07> / XC70 '07> General
Register Members CarsBlogs Help Calendar Mark Forums Read

Notices

S80 '06> / V70 '07> / XC70 '07> General Forum for the Volvo S80 '06> / V70 '07> XC70 '07> models (V70 Generation 3)

Information
  • VOC Members: There is no login facility using your VOC membership number or the details from page 3 of the club magazine. You need to register in the normal way
  • AOL Customers: Make sure you check the 'Remember me' check box otherwise the AOL system may log you out during the session. This is a known issue with AOL.
  • AOL, Yahoo and Plus.net users. Forum owners such as us are finding that AOL, Yahoo and Plus.net are blocking a lot of email generated from forums. This may mean your registration activation and other emails will not get to you, or they may appear in your spam mailbox

Thread Informations

No loudspeaker output.

Views : 540

Replies : 6

Users Viewing This Thread :  

Reply
 
Thread Tools Display Modes
Old Nov 13th, 2014, 14:36   #1
dalo57
New Member
 

Last Online: Yesterday 17:11
Join Date: Nov 2006
Location: swansea
Default No loudspeaker output.

Bought 2012 V70 D5 auto ex police, and between time I first saw it and now lost output from speakers. Checked fuses, removed floating console (to move info screen back up the bump in dash) reset plug in back of radio and heating unit but still no output. Screen says speakers on. Did not remove CD player. Is loudspeaker output there? Any help would be appreciated.

Last edited by dalo57; Nov 13th, 2014 at 14:44.
dalo57 is offline   Reply With Quote
Old Nov 13th, 2014, 14:53   #2
dalo57
New Member
 

Last Online: Yesterday 17:11
Join Date: Nov 2006
Location: swansea
Default

Previously had an 1996 ex police 850 T5 auto and a 1997 V70 T5 Auto. The new D5 is pretty quick, don't notice huge difference. But the radio worked in them!
dalo57 is offline   Reply With Quote
Old Nov 14th, 2014, 13:40   #3
dalo57
New Member
 

Last Online: Yesterday 17:11
Join Date: Nov 2006
Location: swansea
Default

Got CD player out this morning, appears to be amplifier and radio. Speaker cables come out of back. Half the wires (approx) have been cut and joined to a non standard loom that goes down to the centre nick nack box. The police must have had a switch down there. Two other cables come in here from new fuse box alongside the two fuse boxes under the glove box.
I'm going to rejoin all the cables at the back of the CD and remove all the non standard wires. Also a wire from the gear selector has been cut, but can't see what it does. Think I'll get new Haynes for the wiring diagram. Need a better soldering iron too!
dalo57 is offline   Reply With Quote
The Following User Says Thank You to dalo57 For This Useful Post:
Old Nov 27th, 2014, 20:00   #4
dalo57
New Member
 

Last Online: Yesterday 17:11
Join Date: Nov 2006
Location: swansea
Default

Success! There are 4 plugs in the back of the DC/amplifier. One plug has 8 wires coming out and I reckoned that was the loudspeaker output. (2 wires to 4 speakers). All these had been cut and wires soldered in. There were 20 wires in the new loom and 12v (red) and earth (black) had been siamesed in to give power and earth to the new loom. These was a 20 pin socket at the end. 8 in, 8 back, red and black in don't know where the other two went. Cut whole loom out and reconnected wires. Took about 2 hours to do.

Connected battery up and sound from speakers! I must have heard another car with output from radio; it was impossible for this one to work previously.

Now to remove all the other wires.
dalo57 is offline   Reply With Quote
Old Sep 21st, 2017, 11:55   #5
Puffster
Junior Member
 
Puffster's Avatar
 

Last Online: Yesterday 18:09
Join Date: Feb 2012
Location: London
Default

Ah! I'm wondering if this will help with my issue, which is only the front passenger speaker seems to be working on my ex-police XC70...

Was it Essex police by any chance? Or do they all do this to stop plod listening to music whilst they're sitting around?
__________________
Blue 2011 Volvo XC70 D5 AWD ES - Current
Grey 2005 Volvo XC70 D5 AWD SE - Gone after 230,000 miles
Puffster is offline   Reply With Quote
Old Sep 30th, 2017, 21:58   #6
Puffster
Junior Member
 
Puffster's Avatar
 

Last Online: Yesterday 18:09
Join Date: Feb 2012
Location: London
Default

Yes - wires were cut, so had to join them & now all working
__________________
Blue 2011 Volvo XC70 D5 AWD ES - Current
Grey 2005 Volvo XC70 D5 AWD SE - Gone after 230,000 miles
Puffster is offline   Reply With Quote
Old Nov 14th, 2017, 19:47   #7
LikesToFly
Junior Member
 

Last Online: Nov 16th, 2017 22:00
Join Date: Feb 2013
Location: Elgin
Default

Even if none of the wires were cut, all UK Authorities Volvos came from the factory with audio cable disconnected.

If you want to get the Radio/CD to work, remove and take the Fibre Optic brace out of the wiring, which is directly behind the radio/CD (your right-hand side which has a black 2-pin housing with two orange wires in it). Remove the brace and then connect the male end of the connector in to the back of the radio/CD.

Newer models are not able ot have the in car entertainment disconnected as the cars warning tones are routed through this.
LikesToFly is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 20:12.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.