Volvo Community Forum. The Forums of the Volvo Owners Club

Forum Rules Volvo Owners Club About VOC Volvo Gallery Links Volvo History Volvo Press
Go Back   Volvo Owners Club Forum > "Technical Topics" > S80 '06> / V70 '07> / XC70 '07> General
Register Members CarsBlogs Help Calendar Mark Forums Read

Notices

S80 '06> / V70 '07> / XC70 '07> General Forum for the Volvo S80 '06> / V70 '07> XC70 '07> models (V70 Generation 3)

Information
  • VOC Members: There is no login facility using your VOC membership number or the details from page 3 of the club magazine. You need to register in the normal way
  • AOL Customers: Make sure you check the 'Remember me' check box otherwise the AOL system may log you out during the session. This is a known issue with AOL.
  • AOL, Yahoo and Plus.net users. Forum owners such as us are finding that AOL, Yahoo and Plus.net are blocking a lot of email generated from forums. This may mean your registration activation and other emails will not get to you, or they may appear in your spam mailbox

Thread Informations

D5 - no power when kick down

Views : 2324

Replies : 55

Users Viewing This Thread :  

Reply
 
Thread Tools Display Modes
Old Sep 7th, 2018, 11:07   #31
NorthantsPete
Member
 
NorthantsPete's Avatar
 

Last Online: Oct 26th, 2018 10:04
Join Date: Mar 2015
Location: Northampton
Default

Great - the more research is done the more we can get this to conclude a fix.

Keep us updated here on any patters/findings
__________________
2007 Mk3 V70 D5 2.4 Auto
*expired* 2000 Mk2 V70 2.4T SE Auto 135k
Northampton, UK
NorthantsPete is offline   Reply With Quote
Old Sep 7th, 2018, 11:52   #32
Fatskeleton
Junior Member
 

Last Online: Yesterday 11:39
Join Date: Jul 2018
Location: southport
Default

Quote:
Originally Posted by NorthantsPete View Post
Great - the more research is done the more we can get this to conclude a fix.

Keep us updated here on any patters/findings
will do
Fatskeleton is offline   Reply With Quote
Old Sep 10th, 2018, 08:28   #33
Fatskeleton
Junior Member
 

Last Online: Yesterday 11:39
Join Date: Jul 2018
Location: southport
Default

once again when joining the bypass after putting fuel in, booted it and it went into limp mode. When I came to a stop 6 miles down the road I stopped the engine and restarted it, an it was fine and went like a rocket. is it an electrical fault?? I cant get my head round it. If it was mechanical wouldn't it be there all the time?
Fatskeleton is offline   Reply With Quote
Old Sep 10th, 2018, 09:01   #34
NorthantsPete
Member
 
NorthantsPete's Avatar
 

Last Online: Oct 26th, 2018 10:04
Join Date: Mar 2015
Location: Northampton
Default

So I plugged in my ecu ODB2 reader - it found since last reset an issue with the egr being out of range - i think it could be sticking or not able to open.

Im beginning to think these should only be run on premium fuel as the d4s are now suffering due to poor diesel and some taxi firms switched permenantly to premium. My avensis would only work right on premium.

Ive not had it yet on bp ultimate, so will continue to use premium and check back.

I would recommend for you, Archoil 6400 additive (25 one off treatment) then premium fuel only and see how you get on

reading the manual it states also that half filling a tank results in more condensation, so a much needed filter change is required regulalry - also worth looking at.

I am currently testing the mpg to ratio.
__________________
2007 Mk3 V70 D5 2.4 Auto
*expired* 2000 Mk2 V70 2.4T SE Auto 135k
Northampton, UK
NorthantsPete is offline   Reply With Quote
Old Sep 10th, 2018, 09:11   #35
Fatskeleton
Junior Member
 

Last Online: Yesterday 11:39
Join Date: Jul 2018
Location: southport
Default

I am going to clean the turbo solenoid valve as it seems an easy job. But why would the fuel have anything to do with the turbo? Plus the cost of premium 1.51 a litre!!!
Fatskeleton is offline   Reply With Quote
Old Sep 10th, 2018, 13:03   #36
NorthantsPete
Member
 
NorthantsPete's Avatar
 

Last Online: Oct 26th, 2018 10:04
Join Date: Mar 2015
Location: Northampton
Default

you may find its red herring or additonal work.

The exit port on the turno would be affected by bad burn of course
__________________
2007 Mk3 V70 D5 2.4 Auto
*expired* 2000 Mk2 V70 2.4T SE Auto 135k
Northampton, UK
NorthantsPete is offline   Reply With Quote
Old Sep 14th, 2018, 08:32   #37
NorthantsPete
Member
 
NorthantsPete's Avatar
 

Last Online: Oct 26th, 2018 10:04
Join Date: Mar 2015
Location: Northampton
Default

The saga continues....

So I started with 25 of BP Ultimate from a station i found was cheapest in the area. I did 200 miles of bliss - loads of torque, autobox didnt bother shifting down to get power as there was more low end torque and it sounded sweet as a nut really smooth!

I thought "this is the solution!" so I filled up with 45 of BP ultimate from the same petrol station (still cheapest at 1.42)

The car is now driving like crap! Clattery, limp mode within 5 mins of motorway cruising with the cruise control on. NExt day, same thing, today same, switch off at macdonalds, turn on and dont cruise but rev.. its a bit disgruntled to begin with but eventually opens up more and more until power restored20 miles later (of leaving triptronic in gear, revving 3k+ and leaving it in 5th ont he motorway.


So, i dont know what to think. either its cleanign stuff up and needs an italian tuneup as a result or something else like it doesnt like premium fuel



Ill stick with it, same bp stuff for a month and report back - next month is shell Vpower
__________________
2007 Mk3 V70 D5 2.4 Auto
*expired* 2000 Mk2 V70 2.4T SE Auto 135k
Northampton, UK
NorthantsPete is offline   Reply With Quote
Old Sep 14th, 2018, 12:48   #38
simonroberts
New Member
 

Last Online: Sep 14th, 2018 15:56
Join Date: Jan 2006
Location: Devon
Default

Fixed the issue with mine
2008 185bhp D5 Auto 150kmiles!

Swirl Flap arm detached (has been for +2yrs) was causing the following fault codes and temporally putting the car into a low power mode - the engine fault light did NOT come on even though the codes had been recorded - re-attaching the arm with a bodge to keep it in place, cleared the codes and all good for the last 5days !

Fault codes as reported by a friends Foxwell code reader (not DiCE), my cheap ODB2 reader didn't return any codes!
- P010116 Mass or volume air flow circuit range/performance, general electrical failures, circuit voltage below threshold
- P201500 Intake manifold runner position sensor/switch circuit range/performance - (aka Swirl Flap)

I will post the VIDA summary of these codes when I'm back home, as under the P010116 MAF fault code diagnostics it said check the swirl flap linkage so this is a known issue relating to the 2 systems (in my case under high rev's)

Symptoms:
When accelerating normally no issues and the car would pull normally, lots of power and rev to the red line.
But, if I held the rev's at about 3,000rpm for a slightly longer period (>30sec's or so) ether whilst stationary or driving, it would temporarily go into a low power mode every time, and would then limit the rev's to 4,100rpm max.
If you backed off and let the revs drop below 2,000rpm it would clear the issue


Probably one of many causes of the engine going into the 'low power mode', but hope this helps someone....

The key thing for me is the fact that fault codes had been recorded even though the engine fault light had not come on, and these codes could not be read back by a basic ODB2 reader - once I was able to access these codes it made diagnoses 100% easier

Last edited by simonroberts; Sep 14th, 2018 at 13:08.
simonroberts is offline   Reply With Quote
Old Sep 14th, 2018, 15:41   #39
NorthantsPete
Member
 
NorthantsPete's Avatar
 

Last Online: Oct 26th, 2018 10:04
Join Date: Mar 2015
Location: Northampton
Default

almost same for.me.but its not that predictable... i did get the same ecu error code though just not the second one.


so ive been out twice, no cruising (not gay) and no problems. i do wonde if the dpf gets clogged as it reminds me of when i had dirt in my carboreter or wheba catb isnt tuned properly.

on that note i never get notified of regeneration? should i?
__________________
2007 Mk3 V70 D5 2.4 Auto
*expired* 2000 Mk2 V70 2.4T SE Auto 135k
Northampton, UK
NorthantsPete is offline   Reply With Quote
Old Sep 17th, 2018, 09:12   #40
NorthantsPete
Member
 
NorthantsPete's Avatar
 

Last Online: Oct 26th, 2018 10:04
Join Date: Mar 2015
Location: Northampton
Default

Well the bp ultimate trial came to an abrupt end. The car sounded like a tractor and only got 230 miles from 45!


Back onto shell vpower for a known good source and my what a diffrence, sounds like a petrol v6 now, smooth. However once again this morning, cruise control set to 70, after 5 mins i put my foot down and theres no power. Its not entirely fair as theres still bp in the tank so lets see how this goes.

Next im going to try Esso premium after two tanks of shell
__________________
2007 Mk3 V70 D5 2.4 Auto
*expired* 2000 Mk2 V70 2.4T SE Auto 135k
Northampton, UK
NorthantsPete is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 08:16.


Powered by vBulletin
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.