Volvo Community Forum. The Forums of the Volvo Owners Club

Forum Rules Volvo Owners Club About VOC Volvo Gallery Links Volvo History Volvo Press
Go Back   Volvo Owners Club Forum > "Technical Topics" > S80 '98-'06 / S60 '00-'09 / V70 & XC70 '00-'07 General > ETM Issues
Register Members CarsBlogs Help Calendar Mark Forums Read

Notices

ETM Issues Discuss issues regarding the problems with ETMs fitted to Volvo cars.

Information
  • VOC Members: There is no login facility using your VOC membership number or the details from page 3 of the club magazine. You need to register in the normal way
  • AOL Customers: Make sure you check the 'Remember me' check box otherwise the AOL system may log you out during the session. This is a known issue with AOL.
  • AOL, Yahoo and Plus.net users. Forum owners such as us are finding that AOL, Yahoo and Plus.net are blocking a lot of email generated from forums. This may mean your registration activation and other emails will not get to you, or they may appear in your spam mailbox

Thread Informations

i have a question just exchange ETM

Views : 2067

Replies : 4

Users Viewing This Thread :  

Reply
 
Thread Tools Display Modes
Old Feb 6th, 2017, 15:54   #1
gsxf1100
Back to Volvos again
 
gsxf1100's Avatar
 

Last Online: Mar 13th, 2017 11:58
Join Date: Feb 2012
Location: guess, maybe next to you soon
Default i have a question just exchange ETM

i just exchanged my ETM for a used one.
the old one had the problem explained in loads of posts.
i sourced another one and after putting it in it has the same symptoms.
incl a long beeeping noise from the moment turning the key, even without starting the engine and approx 3 minutes after switching the ignition off. stops after it clicks.

are both ETM fubar in this case ?

help please as i may have the chance to source another one to try.

2001 V70 2.4 petrol
gsxf1100 is offline   Reply With Quote
Old Feb 22nd, 2017, 10:11   #2
CNGBiFuel
Classic P80 1999 BiFuel
 

Last Online: Oct 9th, 2019 02:12
Join Date: Aug 2012
Location: 48mph Middle Lane M4
Default

Why bother? If it's not f'ed, soon will be. The Magneto Marelli things are trash, known for it. Fit a Sacer and have done.
__________________
Bifuel V70 Classic 1999 [The Old Grumpy in the Corner, "When I was a lad... blah, bl**dy blah."]
CNGBiFuel is offline   Reply With Quote
Old Apr 12th, 2017, 18:55   #3
EmmaBadger64
New Member
 
EmmaBadger64's Avatar
 

Last Online: Apr 13th, 2017 11:37
Join Date: Apr 2017
Location: Kingston-upon-Thames
Default

CNGBiFuel is right, fitting another s/h Magneti Marelli Italian ****e Box is a complete waste of money, as you can guarantee that one will go the same way, as they all do. Just look at the amount of questions and comments on forums about this topic. I ought to know, my 2001 V70 is currently not running because of this issue.
As for any help from a Volvo Main Stealer, just forget it .
Am looking at sending mine off to Xemodex, as I am sick of the whole issue. US$485, but it is postage paid via FedEx and guaranteed for life afterwards and no software downloading either.
__________________
2001 Volvo V70 170bhp auto petrol
1974 Bentley T1 6.75 litre V8 (currently not running) :-(

Disabled, but still in the fight
EmmaBadger64 is offline   Reply With Quote
Old May 7th, 2017, 14:01   #4
DSK
C70 T5
 
DSK's Avatar
 

Last Online: Yesterday 23:19
Join Date: Sep 2006
Location: Midlands
Default

Quote:
Originally Posted by CNGBiFuel View Post
Why bother? If it's not f'ed, soon will be. The Magneto Marelli things are trash, known for it. Fit a Sacer and have done.
What is a Sacer?
__________________

1999 C70 T5 Coupe / 2000 C70 T5 GT Coupe
1998 S70R / 1995 Toyota Supra Twin Turbo
2007 Mercedes CLS 320 CDI
2007 Suzuki GSXR-1000
DSK is offline   Reply With Quote
Old May 7th, 2017, 18:33   #5
DSK
C70 T5
 
DSK's Avatar
 

Last Online: Yesterday 23:19
Join Date: Sep 2006
Location: Midlands
Default

Quote:
Originally Posted by gsxf1100 View Post
i just exchanged my ETM for a used one.
the old one had the problem explained in loads of posts.
i sourced another one and after putting it in it has the same symptoms.
incl a long beeeping noise from the moment turning the key, even without starting the engine and approx 3 minutes after switching the ignition off. stops after it clicks.

are both ETM fubar in this case ?

help please as i may have the chance to source another one to try.

2001 V70 2.4 petrol
Its possible that you had got another ETM that was as bad as the one you took out if the problem is still identical.

(I was running a 2nd hand ETM for 11,000miles or 11 weeks in my case before that failed).

If you can afford to have your car off the road for a short time, please do look at the contact-less options. As well the american firm there is one if Germany offering the same repair service : www.ecu.de / www.ecu.co.uk
__________________

1999 C70 T5 Coupe / 2000 C70 T5 GT Coupe
1998 S70R / 1995 Toyota Supra Twin Turbo
2007 Mercedes CLS 320 CDI
2007 Suzuki GSXR-1000
DSK is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 14:57.


Powered by vBulletin
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.