Volvo Community Forum. The Forums of the Volvo Owners Club

Forum Rules Volvo Owners Club About VOC Volvo Gallery Links Volvo History Volvo Press
Go Back   Volvo Owners Club Forum > "Technical Topics" > S40 / V40 '96-'04 General
Register Members CarsBlogs Help Calendar Mark Forums Read

Notices

S40 / V40 '96-'04 General Forum for the Volvo S40 and V40 (Classic) Series from 1995-2004.

Information
  • VOC Members: There is no login facility using your VOC membership number or the details from page 3 of the club magazine. You need to register in the normal way
  • AOL Customers: Make sure you check the 'Remember me' check box otherwise the AOL system may log you out during the session. This is a known issue with AOL.
  • AOL, Yahoo and Plus.net users. Forum owners such as us are finding that AOL, Yahoo and Plus.net are blocking a lot of email generated from forums. This may mean your registration activation and other emails will not get to you, or they may appear in your spam mailbox

Thread Informations

Revs rising & falling at idle - never happened before

Views : 319

Replies : 12

Users Viewing This Thread :  

Reply
 
Thread Tools Display Modes
Old Jun 17th, 2019, 10:30   #11
oliverpervasive
Member
 

Last Online: Yesterday 11:39
Join Date: Jul 2008
Location: london
Default S40 revs up and down at idel

Just a FYI - I have a S40 X reg auto petrol.

I had revs going up and down at idle - I could feel it through the steering wheel.

On investigation I found one of my vacuum hoses had come disconnected from the air filter (- goodness knows how as its well supported/connected) - shoved it back in and hey presto - back to normal running.

Im just saying its worth checking your vac hoses first before starting to dismantle things.

Mine was the one from the rear of the air filter.
oliverpervasive is offline   Reply With Quote
The Following User Says Thank You to oliverpervasive For This Useful Post:
Old Jun 17th, 2019, 11:34   #12
loelly
New Member
 

Last Online: Jun 17th, 2019 11:34
Join Date: Sep 2018
Location: Heers
Default

To find vacuum leak spray (all) the hoses with brake cleaner,if it leaks you will hear the revs go up.
loelly is offline   Reply With Quote
The Following User Says Thank You to loelly For This Useful Post:
Old Jun 18th, 2019, 16:47   #13
CharlesStevenson
Premier Member
 
CharlesStevenson's Avatar
 

Last Online: Jun 22nd, 2019 16:11
Join Date: Nov 2000
Location: Peterborough
Default

Quote:
Originally Posted by oliverpervasive View Post
Just a FYI - I have a S40 X reg auto petrol.

I had revs going up and down at idle - I could feel it through the steering wheel.

On investigation I found one of my vacuum hoses had come disconnected from the air filter (- goodness knows how as its well supported/connected) - shoved it back in and hey presto - back to normal running.

Im just saying its worth checking your vac hoses first before starting to dismantle things.

Mine was the one from the rear of the air filter.

Thx for that. That reminds me of an 850 auto I bought off ebay a few years ago. It was cutting out when coming off the accelerator & when I got home I found that there was a massive split in one of the air hoses! How the previous owner hadn't noticed & dealt with it before I can't fathom! A few pieces of duck tape as a quick fix and all was good until I got a proper replacement.
__________________
Now: V40 1.6 XS X reg manual 131k
Then: Misc Volvo, Saab, BMW, MB, Ford, Vx, Opel, Fiat, Rover, Porsche, Alfa, Austin & others.
CharlesStevenson is offline   Reply With Quote
The Following User Says Thank You to CharlesStevenson For This Useful Post:
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 10:05.


Powered by vBulletin
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.