Volvo Community Forum. The Forums of the Volvo Owners Club

Forum Rules Volvo Owners Club About VOC Volvo Gallery Links Volvo History Volvo Press
Go Back   Volvo Owners Club Forum > "Technical Topics" > S40 / V50 '04-'12 / C70 '06> / C30 '07-'12 General
Register Members CarsBlogs Help Calendar Mark Forums Read

Notices

S40 / V50 '04-'12 / C70 '06> / C30 '07-'12 General Forum for the S40 / V50 '04> / C70 '06> /C30 '07> models.

Information
  • VOC Members: There is no login facility using your VOC membership number or the details from page 3 of the club magazine. You need to register in the normal way
  • AOL Customers: Make sure you check the 'Remember me' check box otherwise the AOL system may log you out during the session. This is a known issue with AOL.
  • AOL, Yahoo and Plus.net users. Forum owners such as us are finding that AOL, Yahoo and Plus.net are blocking a lot of email generated from forums. This may mean your registration activation and other emails will not get to you, or they may appear in your spam mailbox

Thread Informations

Electrical issues

Views : 338

Replies : 16

Users Viewing This Thread :  

Reply
 
Thread Tools Display Modes
Old Oct 11th, 2018, 10:16   #11
ianwlfc96
New Member
 

Last Online: Oct 21st, 2018 12:34
Join Date: Dec 2009
Location: manchester
Default

Hi,

Yes that is correct, while I am driving the car if the interior light is switched on all the dials die and lights go off, its very bizarre.
ianwlfc96 is offline   Reply With Quote
Old Oct 11th, 2018, 10:25   #12
LizardOfBodom
Premier Member
 
LizardOfBodom's Avatar
 

Last Online: Today 12:30
Join Date: May 2016
Location: Dublin/Meath
Default

Quote:
Originally Posted by ianwlfc96 View Post
Hi,

Yes that is correct, while I am driving the car if the interior light is switched on all the dials die and lights go off, its very bizarre.
Wow, huh.
It may happen you have 2 issues - as you pointed out your car "dies" while driving, I assume you mean it chokes etc similary to switching off ignition while driving? that points to SCU as Clan said, but the interior light making dash to loose power - I think there may be something else related to it, just no clue what as never come across this before...

So dashboard "dies" but car still drives fine? What about icons on dash, like indictors or high beam? Im trying to understand if that behaves like you cut off the power to dash completely?
Also, does that also happen when you switch only "reading" lights? (the ones that doesnt relate to main interior lights, on sides of the dome).
__________________
2005 V50 T5AWD M66, Stage1 Hilton tune
E-focus torque mount, E46 bi-xenon retrofit v2 , DTSC fully-off mod, Black Diamond braided b.l.+Brembo discs+ATE ceramic pads
LizardOfBodom is offline   Reply With Quote
Old Oct 11th, 2018, 19:57   #13
ianwlfc96
New Member
 

Last Online: Oct 21st, 2018 12:34
Join Date: Dec 2009
Location: manchester
Default

Hi, sorry for the late reply.

Yes it's only when the interior light is turned on, everything is fine with only the reading lights on.

When driving if you turn the interior light on car drives fine all the dials and all illumination go off, indicators work outside main beam fine.

When it turns off if you like while driving it normally happens in the first 5 mins in to a journey it will do it once maybe twice in quick succession tbh. Quit bizarre really.
ianwlfc96 is offline   Reply With Quote
Old Oct 12th, 2018, 11:00   #14
LizardOfBodom
Premier Member
 
LizardOfBodom's Avatar
 

Last Online: Today 12:30
Join Date: May 2016
Location: Dublin/Meath
Default

Quote:
Originally Posted by ianwlfc96 View Post
Hi, sorry for the late reply.

Yes it's only when the interior light is turned on, everything is fine with only the reading lights on.

When driving if you turn the interior light on car drives fine all the dials and all illumination go off, indicators work outside main beam fine.
....
Never come across this before, its like the signal from interior light created disruption of power supply to dash... What about waterfall console - also looses button/infotainment illumination?

Have to admit I am out of ideas... :/
__________________
2005 V50 T5AWD M66, Stage1 Hilton tune
E-focus torque mount, E46 bi-xenon retrofit v2 , DTSC fully-off mod, Black Diamond braided b.l.+Brembo discs+ATE ceramic pads
LizardOfBodom is offline   Reply With Quote
Old Oct 12th, 2018, 16:43   #15
TheFiend
C30 R-Design
 

Last Online: Today 11:31
Join Date: Mar 2013
Location: Cumbria
Default

Quote:
Originally Posted by LizardOfBodom View Post
Never come across this before, its like the signal from interior light created disruption of power supply to dash... What about waterfall console - also looses button/infotainment illumination?

Have to admit I am out of ideas... :/
It could be a short to earth through the interior light circuit. I have known lamps short to earth when they've blown. I once came across this problem on a coach I drove. Replaced the lamp and things started working correctly.
TheFiend is offline   Reply With Quote
The Following User Says Thank You to TheFiend For This Useful Post:
Old Oct 12th, 2018, 17:23   #16
IainG
Master Member
 

Last Online: Today 15:36
Join Date: Apr 2013
Location: Plymouth
Default

Hi

Quote:
Originally Posted by ianwlfc96 View Post
Good evening all,

2005 Volvo V50 2.0d 180000+ miles

I hope that somebody can help me.

I have recently changed my passenger headlight full unit along with the plug as it was all corroded, all the wires were rejoined colour for colour and soldered them together. The headlight works fine.

Now the interesting part, when I put my key in the ignition turn it to stage 2 no lights on the dash no clocks nothing!! Until the interior light goes out then it all comes to life?? While I'm driving if you turn the interior light on all the dash goes off again??

Another thing it has started to do is now and again it is almost like someone has turned the car off for a split second which is quit unerring.


If I just turn the key straight to turn it over it all flickers then comes to life. The car starts regardless of what I do so no issues there.

Any help would be greatly appreciated.
If it has only happened since you did the soldering it might be worth double checking all your solder joints again for shorts or earths, damaged insulation , unless it is just a coincidence.
Also if you had to move the loom to solder it could it be damaged further along?

Iain
IainG is online now   Reply With Quote
The Following User Says Thank You to IainG For This Useful Post:
Old Oct 13th, 2018, 13:50   #17
ianwlfc96
New Member
 

Last Online: Oct 21st, 2018 12:34
Join Date: Dec 2009
Location: manchester
Default

Yes centre console is fine, it is literally just clocks and and dash??

Thanks anyway I think it might be a case of re-soldering the wires and see if that sorts it.
ianwlfc96 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 15:52.


Powered by vBulletin
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.