Volvo Community Forum. The Forums of the Volvo Owners Club

Forum Rules Volvo Owners Club About VOC Volvo Gallery Links Volvo History Volvo Press
Go Back   Volvo Owners Club Forum > "Technical Topics" > S60 '10> / V60 '11> / XC60 '08>'17 General
Register Members CarsBlogs Help Calendar Mark Forums Read

Notices

S60 '10> / V60 '11> / XC60 '08>'17 General Forum for the Volvo x60 Series of cars

Information
  • VOC Members: There is no login facility using your VOC membership number or the details from page 3 of the club magazine. You need to register in the normal way
  • AOL Customers: Make sure you check the 'Remember me' check box otherwise the AOL system may log you out during the session. This is a known issue with AOL.
  • AOL, Yahoo and Plus.net users. Forum owners such as us are finding that AOL, Yahoo and Plus.net are blocking a lot of email generated from forums. This may mean your registration activation and other emails will not get to you, or they may appear in your spam mailbox

Thread Informations

Screeching noise XC60

Views : 336

Replies : 12

Users Viewing This Thread :  

Reply
 
Thread Tools Display Modes
Old Oct 13th, 2017, 15:34   #11
Deadloak
Junior Member
 
Deadloak's Avatar
 

Last Online: Oct 16th, 2017 11:46
Join Date: Dec 2016
Location: Winchester
Default

Quote:
Originally Posted by Maverick440 View Post
Im sort of airing to it being a wheel brearing noise, as it seams more road speed than engine rpm releted.
Only lasts a short while then stops and only seams to be from a cold start.
Mine has done it twice now.
Monday, was the worst one and started after about a mile and lasted for probably half a mile down the road.
Today i noticed it again, diffrent road but again after about a mile but this time was not a pronounced as it was on Monday.

Car has done aproximatly 10,000 miles
Mine is about the same mileage, but has be doing it on and off (mornings only - on moist mornings) for the last 2 months.
__________________
2017 V60 SE LUX Nav auto- Magic Blue WP/RC/DAP
Deadloak is offline   Reply With Quote
Old Oct 14th, 2017, 15:50   #12
Maverick440
Junior Member
 

Last Online: Oct 16th, 2017 21:12
Join Date: Jun 2017
Location: Crewe
Default

Car booked into dealer on the 30th for diagnosis.
Happened again today exactly the same after one mile and lasted about two minutes.
Defiantly rotational / road speed related and stops immediately any break pressure is applied so I'm thinking its a break pad issue.
__________________
XC60 R Design Nav D5 Auto (2017 MY) Polestar Optimised, Savile Gray Winter Pack, Tinted Rear Windows, Leather Faced Seats, Front & Rear Parking Sensors.
Maverick440 is offline   Reply With Quote
Old Oct 15th, 2017, 10:05   #13
844PHW
Master Member
 

Last Online: Oct 15th, 2017 10:07
Join Date: Mar 2011
Location: Surrey, UK
Default

Just a thought, but my xc60 once had a problem where for a few seconds under particular circumstances there was a very metallic screeching noise from somewhere underneath. It turned out to be the underbody heatshield vibrating in resonance to certain circumstances. A couple of the fasteners needing tightening and the problem went away.
__________________
MY11 XC60 D3 Manual SE Premium Terra Bronze
844PHW is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 09:48.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.