Volvo Community Forum. The Forums of the Volvo Owners Club

Forum Rules Volvo Owners Club About VOC Volvo Gallery Links Volvo History Volvo Press
Go Back   Volvo Owners Club Forum > "Technical Topics" > S60 '10> / V60 '11> / XC60 '08>'17 General
Register Members CarsBlogs Help Calendar Mark Forums Read

Notices

S60 '10> / V60 '11> / XC60 '08>'17 General Forum for the Volvo x60 Series of cars

Information
  • VOC Members: There is no login facility using your VOC membership number or the details from page 3 of the club magazine. You need to register in the normal way
  • AOL Customers: Make sure you check the 'Remember me' check box otherwise the AOL system may log you out during the session. This is a known issue with AOL.
  • AOL, Yahoo and Plus.net users. Forum owners such as us are finding that AOL, Yahoo and Plus.net are blocking a lot of email generated from forums. This may mean your registration activation and other emails will not get to you, or they may appear in your spam mailbox

Thread Informations

Calling V60 T6 Polestar Owners

Views : 16884

Replies : 109

Users Viewing This Thread :  

Reply
 
Thread Tools Display Modes
Old Feb 3rd, 2018, 10:39   #101
EWAC
too long to remember
 

Last Online: Aug 18th, 2019 13:26
Join Date: Dec 2004
Location: Leigh on sea
Default

Quote:
Originally Posted by irish boy View Post
Yes thats me. I heard its very elusive to get into
Haha, i have sent you a message through fb messager.
You are the only owner in NI, that i know of
__________________
------------------------------------
V60 Polestar Rebel Blue

Instagram: #polestar_owners_uk Facebook: Polestar owners uk Email: polestarownersuk@gmail.com
EWAC is offline   Reply With Quote
The Following User Says Thank You to EWAC For This Useful Post:
Old Jan 20th, 2019, 22:11   #102
THEFLUTE
New Member
 

Last Online: Sep 3rd, 2019 16:07
Join Date: Dec 2013
Location: leicester
Default

Another 3l owner here. Pick our black one up next week. :-)
THEFLUTE is offline   Reply With Quote
Old Aug 18th, 2019, 08:54   #103
NicM
New Member
 

Last Online: Aug 24th, 2019 10:54
Join Date: Aug 2019
Location: Brighton
Default V60 T6 Polestar

Hi All,

My first post and sorry for the War & Peace but unfortunately having just picked up this immaculate T6 up last Weds I've had / having several issues.

I drove it back from Darlington to Brighton (6 hours) in that atrocious weather, is aquaplaning better with AWD I wonder?

An amazing car despite all my service lights coming on, intermittently cutting out and the alternator smelling like my old '60's train-set transformer about to catch fire.

Took it to Volvo Worthing, nothing serious came up on the diagnostics?? Left and immediately all the lights came back on, returned to Volvo they could smell the car 10 yards away. It's booked in next Friday but to be honest I'm surprised they didn't tell me not to drive the car, seriously it really does seem as though the alternator could cause an engine fire - anyone know if that's possible?

The cutting out first happened at 60 MPH on the M25 in torrential rain, after slight aquaplaning - the car almost came to a halt very scary I felt totally helpless although it was probably no more than 1 second. I immediately put that down to the car just taking on too much water - but really IDK? Bad earth, faulty battery / alternator makes more logic.....

Since then every time I drive the car it just feels like 'lag' the car dips and nothing happens when I accelerate, not every time but it's a bit disconcerting. I'm no expert but combined with the service lights and that smell it surely just needs a new alternator!

Has anyone experienced any of these issues? maybe in the wet? I have Volvo Assistance so not overly concerned but it's not a great start. BTW the car had been sitting unused for around 100 days before I drove it away, which may have some bearing?

My only real criticism of the car, well I need to get this out of the way first, despite those big discs and 6 pot brembo callipers the breaks are not great, they checked the pads but are there better pads to try perhaps?

My V60 Polestar forum.jpg

Cheers.
NicM is offline   Reply With Quote
Old Aug 18th, 2019, 13:15   #104
EWAC
too long to remember
 

Last Online: Aug 18th, 2019 13:26
Join Date: Dec 2004
Location: Leigh on sea
Default

Hi there, this definitely isnt right. Drop me a message

Quote:
Originally Posted by NicM View Post
Hi All,

My first post and sorry for the War & Peace but unfortunately having just picked up this immaculate T6 up last Weds I've had / having several issues.

I drove it back from Darlington to Brighton (6 hours) in that atrocious weather, is aquaplaning better with AWD I wonder?

An amazing car despite all my service lights coming on, intermittently cutting out and the alternator smelling like my old '60's train-set transformer about to catch fire.

Took it to Volvo Worthing, nothing serious came up on the diagnostics?? Left and immediately all the lights came back on, returned to Volvo they could smell the car 10 yards away. It's booked in next Friday but to be honest I'm surprised they didn't tell me not to drive the car, seriously it really does seem as though the alternator could cause an engine fire - anyone know if that's possible?

The cutting out first happened at 60 MPH on the M25 in torrential rain, after slight aquaplaning - the car almost came to a halt very scary I felt totally helpless although it was probably no more than 1 second. I immediately put that down to the car just taking on too much water - but really IDK? Bad earth, faulty battery / alternator makes more logic.....

Since then every time I drive the car it just feels like 'lag' the car dips and nothing happens when I accelerate, not every time but it's a bit disconcerting. I'm no expert but combined with the service lights and that smell it surely just needs a new alternator!

Has anyone experienced any of these issues? maybe in the wet? I have Volvo Assistance so not overly concerned but it's not a great start. BTW the car had been sitting unused for around 100 days before I drove it away, which may have some bearing?

My only real criticism of the car, well I need to get this out of the way first, despite those big discs and 6 pot brembo callipers the breaks are not great, they checked the pads but are there better pads to try perhaps?

Attachment 121917

Cheers.
__________________
------------------------------------
V60 Polestar Rebel Blue

Instagram: #polestar_owners_uk Facebook: Polestar owners uk Email: polestarownersuk@gmail.com
EWAC is offline   Reply With Quote
Old Aug 18th, 2019, 13:17   #105
EWAC
too long to remember
 

Last Online: Aug 18th, 2019 13:26
Join Date: Dec 2004
Location: Leigh on sea
Default

Quote:
Originally Posted by THEFLUTE View Post
Another 3l owner here. Pick our black one up next week. :-)
Not sure if we have spoken or got in touch. If not, drop me a message
__________________
------------------------------------
V60 Polestar Rebel Blue

Instagram: #polestar_owners_uk Facebook: Polestar owners uk Email: polestarownersuk@gmail.com
EWAC is offline   Reply With Quote
Old Aug 18th, 2019, 13:21   #106
NicM
New Member
 

Last Online: Aug 24th, 2019 10:54
Join Date: Aug 2019
Location: Brighton
Default

Hi - thanks for the reply I just tried to do that but I'm not allowed being a new member?

Quote:
Originally Posted by EWAC View Post
Not sure if we have spoken or got in touch. If not, drop me a message
NicM is offline   Reply With Quote
Old Aug 18th, 2019, 13:26   #107
EWAC
too long to remember
 

Last Online: Aug 18th, 2019 13:26
Join Date: Dec 2004
Location: Leigh on sea
Default

Quote:
Originally Posted by NicM View Post
Hi - thanks for the reply I just tried to do that but I'm not allowed being a new member?
Use the email address below 👇
__________________
------------------------------------
V60 Polestar Rebel Blue

Instagram: #polestar_owners_uk Facebook: Polestar owners uk Email: polestarownersuk@gmail.com
EWAC is offline   Reply With Quote
Old Aug 18th, 2019, 13:29   #108
NicM
New Member
 

Last Online: Aug 24th, 2019 10:54
Join Date: Aug 2019
Location: Brighton
Default

Done that, thanks and apologies I replied using the wrong quote earlier.

Quote:
Originally Posted by EWAC View Post
Use the email address below 👇
NicM is offline   Reply With Quote
Old Aug 20th, 2019, 18:33   #109
NicM
New Member
 

Last Online: Aug 24th, 2019 10:54
Join Date: Aug 2019
Location: Brighton
Default V60 T6 Polestar

A quick update:

After a short 10 min drive today and up a very steep incline, I returned home, very strong smell, popped the hood and smoke coming out, not enough to call the fire brigade but enough to make me look for the Volvo Fire Extinguisher which doesn't exist, all manufacturers should supply one in my opinion.

Called Volvo Assistance - immediately the guy who came to collect it said he could smell the clutch! Yes I knew that smell was reminiscent of something other than my old train set transformer.

So my electric / alternator theory could be a complete red herring. The cutting out I was experiencing could be the clutch slipping. The car's only done 20K so unless the handbrake was on all the time what could make this happen even if the previous owner drove it hard and it doesn't look like that. Maybe a faulty stop/start switch? Anyway everything at this stage is still speculative.

Hope to get a report from Volvo later tomorrow.
NicM is offline   Reply With Quote
Old Aug 23rd, 2019, 16:52   #110
NicM
New Member
 

Last Online: Aug 24th, 2019 10:54
Join Date: Aug 2019
Location: Brighton
Default V60 T6 Polestar

Volvo have diagnosed the problem:

"We have diagnosed the problem with your car, The clutch on the super charger has failed (which explains both the burning smell and lack of power etc.
This is part is not available until next Wednesday as it has to come from Sweden"

I found this interesting article about twin-charging which shows the offending item. Of course the million dollar question is what caused it to fail?

https://www.roadandtrack.com/car-cul...-power-couple/

Cheers.
NicM is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 17:43.


Powered by vBulletin
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.