Volvo Community Forum. The Forums of the Volvo Owners Club

Forum Rules Volvo Owners Club About VOC Volvo Gallery Links Volvo History Volvo Press
Go Back   Volvo Owners Club Forum > "Technical Topics" > S40 / V50 '04-'12 / C70 '06> / C30 '07-'12 General
Register Members CarsBlogs Help Calendar Mark Forums Read

Notices

S40 / V50 '04-'12 / C70 '06> / C30 '07-'12 General Forum for the S40 / V50 '04> / C70 '06> /C30 '07> models.

Information
  • VOC Members: There is no login facility using your VOC membership number or the details from page 3 of the club magazine. You need to register in the normal way
  • AOL Customers: Make sure you check the 'Remember me' check box otherwise the AOL system may log you out during the session. This is a known issue with AOL.
  • AOL, Yahoo and Plus.net users. Forum owners such as us are finding that AOL, Yahoo and Plus.net are blocking a lot of email generated from forums. This may mean your registration activation and other emails will not get to you, or they may appear in your spam mailbox

Thread Informations

ecu (possibly)

Views : 182

Replies : 6

Users Viewing This Thread :  

Reply
 
Thread Tools Display Modes
Old May 17th, 2019, 16:23   #1
jimjam440si
Member
 

Last Online: Today 07:24
Join Date: Jul 2010
Location: gillingham
Default ecu (possibly)

hi all, im after some advice, ive got an 06 s40. the battery keeps going flat, ive had that and the alternator checked and bot hare fine, the car also beeps every 2 to 3 mins ive been told this is the ecu that could be at fault, hopefully one of yo good people understand me and can point me in the right direction ,thanks
jimjam440si is offline   Reply With Quote
Old May 20th, 2019, 13:40   #2
jimjam440si
Member
 

Last Online: Today 07:24
Join Date: Jul 2010
Location: gillingham
Default

anyone???????
jimjam440si is offline   Reply With Quote
Old May 20th, 2019, 14:15   #3
StatusRed
Premier Member
 

Last Online: Yesterday 21:25
Join Date: Jul 2015
Location: Glasgow
Default

My battery kept going flat and it turned out it was the insurance black box which was installed 2 years previously, I ripped it out myself and it's been fine since.

So, if you don't have a black box leeching power I'd assume it's something else leeching.. Any accessories plugged in? Or maybe it's the ECU that's draining power somehow.
__________________
2009 S40 SE Lux 2.0i | 1999 C70 Coupé 2.4i

e-Focus torque mount | Retrofitted undertray | Painted brake calipers | Braided steel brake lines
Previous: 2004 Saab 9-5 Aero Estate
StatusRed is offline   Reply With Quote
Old May 20th, 2019, 15:28   #4
SwissXC90
Premier Member
 

Last Online: Today 05:26
Join Date: Jan 2016
Location: Cross Country
Default

Quote:
Originally Posted by jimjam440si View Post
hi all, im after some advice, ive got an 06 s40. the battery keeps going flat, ive had that and the alternator checked and bot hare fine, the car also beeps every 2 to 3 mins ive been told this is the ecu that could be at fault, hopefully one of yo good people understand me and can point me in the right direction ,thanks
The right direction to point you in is this one:
1. Use VIDA and check for any fault codes. Clear all you find, fix what will not clear.
2. Apply standard diagnostic techniques to determine if any device is consuming power when it should not. This will involve logic, determination, documentation, perseverance, and a dose of experience. And the right tools (multimeter).

Focus on the "beeps every 2 to 3 mins"
Find out what is beeping and why.
If there is no logical reason for the beep then start using diagnostic equipment (VIDA) to determine the cause.
__________________
XC90 R-Design MY2009, Black Sapphire Metallic. HP-Sound, RSE, Nav, Tel, ParkingCam, BLIS, ParkingHeater, RestHeat, Removable Towbar, Summer: CRATUS 20x8 on Pirelli Scorpion Zeros 255/45, Winter: NEPTUNE 17x7 on Continental WinterContact 4x4 235/65.
SwissXC90 is offline   Reply With Quote
Old May 20th, 2019, 18:28   #5
Bungo
Premier Member
 

Last Online: Jun 7th, 2019 14:28
Join Date: Sep 2015
Location: Midlands
Default

I've a feeling the beep is a warning about the flat battery.
Without getting it plugged into Vida you'll be mostly guessing.
Could be a bad earth somewhere possibly the starter motor.
__________________
2008 S40 2.0d R design auto powershift
Bungo is offline   Reply With Quote
Old May 21st, 2019, 11:35   #6
jimjam440si
Member
 

Last Online: Today 07:24
Join Date: Jul 2010
Location: gillingham
Default

whats vida please?
jimjam440si is offline   Reply With Quote
Old May 21st, 2019, 18:59   #7
StatusRed
Premier Member
 

Last Online: Yesterday 21:25
Join Date: Jul 2015
Location: Glasgow
Default

Quote:
Originally Posted by jimjam440si View Post
whats vida please?
Volvo's specific diagnostics software. You can either take it to a dealer or Volvo specialist to get scanned, or ask to see if anyone local to you on the forums has one and can help.

I have one for example and would help but I'm in Glasgow haha.
__________________
2009 S40 SE Lux 2.0i | 1999 C70 Coupé 2.4i

e-Focus torque mount | Retrofitted undertray | Painted brake calipers | Braided steel brake lines
Previous: 2004 Saab 9-5 Aero Estate
StatusRed is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 11:22.


Powered by vBulletin
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.