Volvo Community Forum. The Forums of the Volvo Owners Club

Forum Rules Volvo Owners Club About VOC Volvo Gallery Links Volvo History Volvo Press
Go Back   Volvo Owners Club Forum > "Technical Topics" > S80 '98-'06 / S60 '00-'09 / V70 & XC70 '00-'07 General > ETM Issues
Register Members CarsBlogs Help Calendar Mark Forums Read

Notices

ETM Issues Discuss issues regarding the problems with ETMs fitted to Volvo cars.

Information
  • VOC Members: There is no login facility using your VOC membership number or the details from page 3 of the club magazine. You need to register in the normal way
  • AOL Customers: Make sure you check the 'Remember me' check box otherwise the AOL system may log you out during the session. This is a known issue with AOL.
  • AOL, Yahoo and Plus.net users. Forum owners such as us are finding that AOL, Yahoo and Plus.net are blocking a lot of email generated from forums. This may mean your registration activation and other emails will not get to you, or they may appear in your spam mailbox

Thread Informations

Etm

Views : 867

Replies : 1

Users Viewing This Thread :  

Reply
 
Thread Tools Display Modes
Old Jan 18th, 2018, 08:39   #1
bmwshooting
Junior Member
 

Last Online: Aug 19th, 2019 12:29
Join Date: Feb 2012
Location: Heswall
Default Etm

Hi
Wife's v70 2.4 low on power ticks over fine when hot will now and again stutter on power so read with reader says Etm internal electrical fault so sent of to
BBA-Reman after a long battle to get the lead from behind starter motor
Got email off them to say it's fine no issues read some ware that a reload of software off dealer might fix it what effect does a bad MAF throw at you
Rob
bmwshooting is offline   Reply With Quote
Old Jan 18th, 2018, 10:32   #2
100K+
Premier Member
 

Last Online: Today 09:18
Join Date: Aug 2008
Location: Newcastle
Default

A while ago I had an issue with my DEM unit on my 2004 V70 AWD R. Sent my DEM to who you sent your item to. Got clean bill of health. Spent next couple of months chasing my tail trying to get the AWD back. Bottom line - the DEM WAS bad. I'm not the only member who has had false positives from these peps. Not saying your unit is bad.....
The actual issue you have could be many things...if you intend keeping the car and can/like juggling the spanners consider a VIDA/DICE unit, or find someone near by who has. In identifying car troubles they are worth their weight in gold.
If you pull the lead to the MAF and the car runs better the MAF is more than likely faulty. The car runs default values, rather than the values the MAF gives hence it runs ok albeit ALOT heavier (in my experience) in fuel.

Good luck

Cheers
Bob
100K+ is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 13:00.


Powered by vBulletin
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.