Volvo Community Forum. The Forums of the Volvo Owners Club

Forum Rules Volvo Owners Club About VOC Volvo Gallery Links Volvo History Volvo Press
Go Back   Volvo Owners Club Forum > "Technical Topics" > S40 / V50 '04-'12 / C70 '06> / C30 '07-'12 General

Notices

S40 / V50 '04-'12 / C70 '06> / C30 '07-'12 General Forum for the S40 / V50 '04> / C70 '06> /C30 '07> models.

Information
  • VOC Members: There is no login facility using your VOC membership number or the details from page 3 of the club magazine. You need to register in the normal way
  • AOL Customers: Make sure you check the 'Remember me' check box otherwise the AOL system may log you out during the session. This is a known issue with AOL.
  • AOL, Yahoo and Plus.net users. Forum owners such as us are finding that AOL, Yahoo and Plus.net are blocking a lot of email generated from forums. This may mean your registration activation and other emails will not get to you, or they may appear in your spam mailbox

Thread Informations

Volvo V50 1.6D intermittent loss of power

Views : 195

Replies : 3

Users Viewing This Thread :  

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old Nov 22nd, 2020, 16:09   #1
innocent2k
New Member
 

Last Online: Nov 25th, 2020 18:34
Join Date: Mar 2019
Location: Vestfold
Default Volvo V50 1.6D intermittent loss of power

Hi

I have a V50 (as title suggests!) with the following problem. Car starts fine but it judders a bit when driving, not continuously but a lot of the time. I also end up in situations where when I'm driving at arount 110km/h, the engine stops pulling alltogether and even with the accelerator floored it will slowly lose speed. This resolves itself after about 10-15 seconds without me doing anything, which to me suggests it is not going into limp mode (as I believe that would require me to switch off the ignition and re-start to recover from).

While not behaving EXACTLY like last time, the symptoms does remind me a bit about how the car was with a faulty throttle body a few years back. Could this explain the symptoms? Error codes ECM-9140 and ECM-9150 suggests the fault lies there and by checking details the 9140 error indeed gives me a picture of the throttle body. I have also attached the full list of error codes even though I know most are unrelated, but in case I've missed something else that could lead to this. The two permanent ones can be disregarded fully.

Last question, if it is likely to be the throttle body, can this be changed without reprogramming anything? (I would guess so since they can actually be bought as a 3rd party replacement, but I want to make sure before I attempt this on my own). Thanks in advance for any help.

Other info:

- MY2008
- Car has run 155000km, DPF was exchanged at 120000km
- EGR is closed off permanently
- Car had its annual dealership service a few weeks ago
- Fuel filter was last changed two years ago

vida_1.jpg
innocent2k is offline   Reply With Quote
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 22:29.


Powered by vBulletin
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.