Volvo Community Forum. The Forums of the Volvo Owners Club

Forum Rules Volvo Owners Club About VOC Volvo Gallery Links Volvo History Volvo Press
Go Back   Volvo Owners Club Forum > "Technical Topics" > V40/XC '12>17 General

Notices

Information
  • VOC Members: There is no login facility using your VOC membership number or the details from page 3 of the club magazine. You need to register in the normal way
  • AOL Customers: Make sure you check the 'Remember me' check box otherwise the AOL system may log you out during the session. This is a known issue with AOL.
  • AOL, Yahoo and Plus.net users. Forum owners such as us are finding that AOL, Yahoo and Plus.net are blocking a lot of email generated from forums. This may mean your registration activation and other emails will not get to you, or they may appear in your spam mailbox

Thread Informations

V40 D3 - 1 second lag when 100% accel is it normal?

Views : 1680

Replies : 4

Users Viewing This Thread :  

Reply
 
Thread Tools Display Modes
Old Nov 19th, 2023, 23:52   #1
professorsancho
New Member
 

Last Online: Feb 15th, 2024 01:04
Join Date: Nov 2023
Location: Horta
Default V40 D3 - 1 second lag when 100% accel is it normal?

New owner here (V40 D3 2018 manual).

When I full press the acceleration pedal (to give it full 100% power), it takes around 1 to 2 seconds to feel the car going, and then it goes like a train (as it is expected of a 150hp car).

This happens on any rpms. Tried from 1500, 1800, 2000, 2500 and 3000. On second gear it appears to be less lag.

Is this normal on all D3?

Last edited by professorsancho; Nov 19th, 2023 at 23:58.
professorsancho is offline   Reply With Quote
Old Nov 23rd, 2023, 14:18   #2
professorsancho
New Member
 

Last Online: Feb 15th, 2024 01:04
Join Date: Nov 2023
Location: Horta
Default

Just used the Troque app to generate some graphs.
In the attached picture I added the vertical lines to set the exact time I fully pressed the throtle pedal.
The problem is evident: throttle climbs at around 7.5 seconds but the power/hp/torque only starts to climb more than a second later... definetly not normal.
Help is apreciated if anyone can give a possible idea on how to fix this.
Attached Images
File Type: jpg TorqueApp-VolvoV40-Graphs.jpg (347.1 KB, 11 views)
professorsancho is offline   Reply With Quote
Old Dec 19th, 2023, 17:07   #3
anotheruser
Junior Member
 

Last Online: Dec 19th, 2023 17:25
Join Date: Jul 2020
Location: The Midlands
Default

Is it a lag or a delay?

I had a Ford Focus that had this - if you put your foot right down, there would be a lack of power for a second, almost like the engine had stunted your take off.

Turns out, after two or three years, a hairline crack on a spark plug was causing it. After they were all changed, never had the issue again.
__________________
Currently Driving: Volvo V40 | 2016/66 | D3 Momentum
anotheruser is offline   Reply With Quote
Old Dec 19th, 2023, 17:32   #4
Clan
Experienced Member
 
Clan's Avatar
 

Last Online: Yesterday 23:47
Join Date: Jun 2007
Location: L/H side
Default

Quote:
Originally Posted by professorsancho View Post
New owner here (V40 D3 2018 manual).

When I full press the acceleration pedal (to give it full 100% power), it takes around 1 to 2 seconds to feel the car going, and then it goes like a train (as it is expected of a 150hp car).

This happens on any rpms. Tried from 1500, 1800, 2000, 2500 and 3000. On second gear it appears to be less lag.

Is this normal on all D3?
Its hard to say if it's normal without experiencing it.. but a turbocharger does take a measurable amount of time to spin up, . Do you have the twin turbo engine? ( a very small one for your situation, and a big one for high power over say 3000 rpm..) your engine is detuned compared to the D4 and D5 , same engines different electronic map ..
__________________
My comments are only based on my opinions and vast experience .
Clan is offline   Reply With Quote
Old Dec 19th, 2023, 19:44   #5
professorsancho
New Member
 

Last Online: Feb 15th, 2024 01:04
Join Date: Nov 2023
Location: Horta
Default

Delay or lag?
I just had to google the diference... and... i would say its a delay. The car gives 2% nearly instantly when i press the pedal, but then... have to wait 1.5 secs to the other 98% to arrive (its like... 2% for 1.5s and then 100%). Thank you on the suggestion about the spark plugs. Next oil service i will check that and give feedback.

My v40 D3 unfortunatly has only 1 turbo.
I asked 2 other owners with the same car/model and all said they had minimal lag/delay - less than 0.5 secs. I'll make a video after Chrismas showing the problem.

Hummm... I have seen someone talking about the throttle body. That sometimes you had to do the "learning" procedure to fix it.... have no idea what this procedure is...

Last edited by professorsancho; Dec 19th, 2023 at 21:32.
professorsancho is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 09:32.


Powered by vBulletin
Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.