Volvo Community Forum. The Forums of the Volvo Owners Club

Forum Rules Volvo Owners Club About VOC Volvo Gallery Links Volvo History Volvo Press
Go Back   Volvo Owners Club Forum > "Technical Topics" > S60 & V60 '11-'18 / XC60 '09-'17 General

Notices

S60 & V60 '11-'18 / XC60 '09-'17 General Forum for the P3-platform 60-series models

Information
  • VOC Members: There is no login facility using your VOC membership number or the details from page 3 of the club magazine. You need to register in the normal way
  • AOL Customers: Make sure you check the 'Remember me' check box otherwise the AOL system may log you out during the session. This is a known issue with AOL.
  • AOL, Yahoo and Plus.net users. Forum owners such as us are finding that AOL, Yahoo and Plus.net are blocking a lot of email generated from forums. This may mean your registration activation and other emails will not get to you, or they may appear in your spam mailbox

Thread Informations

XC60 2010 CCM problems caused by water ingress

Views : 558

Replies : 1

Users Viewing This Thread :  

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old Nov 21st, 2023, 12:28   #1
Harry28
New Member
 

Last Online: Jan 15th, 2024 14:18
Join Date: Jul 2020
Location: Harborne
Question XC60 2010 CCM problems caused by water ingress

Hi all, I have a 2010 XC60 135000miles.

I have recently had a bit of a water ingress from a leaky windscreen seal, I've had that replaced but unfortunately it's managed to do a bit of damage to what I thought was my climate control module. It popped up with about 16 errors when reading the codes. I have lights on the CCM but I can't control the temperature, fan speed, heated seats or rear defroster.

I bought the same model number CCM from eBay and replaced it, I can now adjust the fan speed slightly but it doesn't get very high, the heated seats, temp control and rear defroster still don't work.

I read the DTCs using Vida and it popped up with:

CCM-B103287 Right Front Seat Heater - Bus Signal / Message Failures - Missing message
CCM-B105A11 Cabin Temperature Sensor Fan - General Electrical Failures - Circuit short to ground
CCM-B108187 Left Temperature Damper Motor - Bus Signal / Message Failures - Missing message
CCM-B108287 Right Temperature Damper Motor - Bus Signal / Message Failures - Missing message
CCM-B108387 Recirculation Damper Motor - Bus Signal / Message Failures - Missing message
CCM-B108587 Defroster Damper Motor - Bus Signal / Message Failures - Missing message
CCM-B108687 Air Distribution Damper Motor - Bus Signal / Message Failures - Missing message
CCM-B128687 Interior Mirror - Bus Signal / Message Failures - Missing message
CCM-B1A6987 Humidity Sensor - Bus Signal / Message Failures - Missing message
CCM-B103087 Left Front Seat Heater - Bus Signal / Message Failures - Missing message
CCM-B10874A LIN Bus A - System Internal Failures - Incorrect component installed
CCM-B108788 LIN Bus A - Bus Signal / Message Failures - Bus off
CCM-B10884A LIN Bus B - System Internal Failures - Incorrect component installed
CCM-B108&88 LIN Bus B - Bus Signal / Message Failures - Bus off
CCM-B10B913 Blower Control - General Electrical Failures - Circuit open
CCM-B10B911 Blower Control - General Electrical Failures - Circuit short to ground


I think there must be a short somewhere in the system but I don't know where to start looking. Has anyone had any similar problems and symptoms?

Any help would be greatly appreciated
Harry28 is offline   Reply With Quote
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 08:33.


Powered by vBulletin
Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.