Volvo Community Forum. The Forums of the Volvo Owners Club

Forum Rules Volvo Owners Club About VOC Volvo Gallery Links Volvo History Volvo Press
Go Back   Volvo Owners Club Forum > "Technical Topics" > XC90 '02'15 General
Register Members CarsBlogs Help Calendar Mark Forums Read

Notices

XC90 '02'15 General Forum for the Volvo XC90 Phase 1 Series

Information
  • VOC Members: There is no login facility using your VOC membership number or the details from page 3 of the club magazine. You need to register in the normal way
  • AOL Customers: Make sure you check the 'Remember me' check box otherwise the AOL system may log you out during the session. This is a known issue with AOL.
  • AOL, Yahoo and Plus.net users. Forum owners such as us are finding that AOL, Yahoo and Plus.net are blocking a lot of email generated from forums. This may mean your registration activation and other emails will not get to you, or they may appear in your spam mailbox

Thread Informations

Nightmare with radio in our XC90

Views : 63127

Replies : 65

Users Viewing This Thread :  

Reply
 
Thread Tools Display Modes
Old Aug 6th, 2015, 01:09   #61
Morinack
New Member
 

Last Online: Aug 6th, 2015 01:09
Join Date: Aug 2015
Location: Larkspur
Default

Quote:
Originally Posted by rowleyd3 View Post
Mine does this occasionally and my fix works for me as advised in other posts. Under the seat there are 3 plugs attached to the amp(?). Take the key out of the ignition, take all 3 plugs out then reseat them - try the radio again.
That works 90% of the time. If that fails, do the same but spray contact cleaner into the 3x plugs and 3xsockets and leave for 10mins to dry - that should do the trick (well it does on mine anyway - thanks to whoever told me previously !!)

The 3 plugs are the ones immediately under the seat if your stick your head in the drivers footwell -the ones on the front of the amp - as per the pic

HTH,

Darren.
Thanks Rowley! Getting ready to ship my ICM out for repair for no reason. This fixed my 2011 XC R right up.
Morinack is offline   Reply With Quote
Old Nov 26th, 2015, 15:33   #62
ampmaster
Junior Member
 

Last Online: Aug 17th, 2016 20:40
Join Date: Aug 2010
Location: cardiff
Default

Hi Clan,
My 05 XC90 I think has had the audio unit changed. It switches on and makes a noise but doesn't actually work. I did investigate it last year and it seems that the replacement has to be within 1000 of the original serial number to work. Am I remembering that correctly? Is there any way to program the car to accept the replacement unit? It is an identical unit from a similar car but the serial numbers are way different. Everything else works, park sensors etc.
I had to change my ECU a while back and boy was that a lot of hassle. I had to get the old one "read", the replacement wiped and programmed with the old units info. It worked though. I discovered that most people are not interested in these jobs and many claim to able to do it and cannot. Last check there were about five in the UK able to do it.
ampmaster is offline   Reply With Quote
Old Nov 26th, 2015, 17:38   #63
ampmaster
Junior Member
 

Last Online: Aug 17th, 2016 20:40
Join Date: Aug 2010
Location: cardiff
Default

Quote:
Originally Posted by alexlouislisa View Post
For anyone interested,
I was told by my volvo main dealer that the ICM was faulty and needed replacing at a cost of........850>>>>>aaagh
Bought one from a salvage yard,fitted it and it works perfectly,no coding ,no software download,
Personally think that main dealers mislead people on purpose.
PS unit from salvage yard was 100
Hope this helps anyone
ICM unit can affect certain dash functions,in my case the dashboard itself suffered intermittent power loss,no speedo etc.
not suer how volvo justify 850 for a part that must cost them nowhere near this,and is easy to fit.
Apparently, if the serial numbers are within 1000 (it may even be more) they will work as they seem to be coded in batches. You may have been fortunate to get one in the same batch as your original. Mine had a replacement from a salvage car (before I owned it) and it does not work properly in my car but was fine in the one it came from.
ampmaster is offline   Reply With Quote
Old Nov 26th, 2015, 22:26   #64
Clan
Experienced Member
 
Clan's Avatar
 

Last Online: Today 10:11
Join Date: Jun 2007
Location: L/H side
Default

Quote:
Originally Posted by ampmaster View Post
Hi Clan,
My 05 XC90 I think has had the audio unit changed. It switches on and makes a noise but doesn't actually work. I did investigate it last year and it seems that the replacement has to be within 1000 of the original serial number to work. Am I remembering that correctly? Is there any way to program the car to accept the replacement unit? It is an identical unit from a similar car but the serial numbers are way different. Everything else works, park sensors etc.
I had to change my ECU a while back and boy was that a lot of hassle. I had to get the old one "read", the replacement wiped and programmed with the old units info. It worked though. I discovered that most people are not interested in these jobs and many claim to able to do it and cannot. Last check there were about five in the UK able to do it.
you might find a friendly dealer to try a reload of the ICM software , but Volvo don't give any support to them if they end up with a dead car so that is why most are reluctant do do any unauthorised work like that . The CEM checks all the serial numbers when the ignition is turned on and The infotainment system will not be allowed to operate if the serial number of the ICM which is stored in teh CEM does not match . a grey area ..

If it were me i would just get the original ICM which worked repaired ...
__________________
My comments are only based on my opinions and vast experience .
Clan is online now   Reply With Quote
Old Nov 27th, 2015, 11:24   #65
ifzal123
Senior Member
 

Last Online: May 31st, 2019 03:27
Join Date: Sep 2014
Location: Birmingham
Default

You will find this thread useful.

Volvo diagnostics repiar the icm for 150 ish


http://www.volvoforums.org.uk/showthread.php?t=226763
ifzal123 is offline   Reply With Quote
Old Jan 12th, 2016, 09:35   #66
Car Wiz
New Member
 

Last Online: Jan 12th, 2016 09:35
Join Date: Jan 2016
Location: Omaha
Default Radio Static noise on XC90 V8

Hello Folks,

I have been battling the radio static noise in 2009 XC90 Executive Edition, first started to be just a static noise when AUX input jack is connected, after that I got huge static when rear entertainment system is on.

After long troubleshooting I have found that AUX Jack inside the cup holder is bad. Simply remove cover and be careful as there is clip holding on both sides of the switch.
How to troubleshoot? = Disconnect the wire from bottom of aux switch and the noise should stop.
Volvo part number # AUX Input : 30790263
Feeling good that noise is away...
Car Wiz is offline   Reply With Quote
The Following User Says Thank You to Car Wiz For This Useful Post:
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 10:12.


Powered by vBulletin
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.