Volvo Community Forum. The Forums of the Volvo Owners Club

Forum Rules Volvo Owners Club About VOC Volvo Gallery Links Volvo History Volvo Press
Go Back   Volvo Owners Club Forum > "Technical Topics" > S80 '06> / V70 '07> / XC70 '07> General
Register Members CarsBlogs Help Calendar Mark Forums Read

Notices

S80 '06> / V70 '07> / XC70 '07> General Forum for the Volvo S80 '06> / V70 '07> XC70 '07> models (V70 Generation 3)

Information
  • VOC Members: There is no login facility using your VOC membership number or the details from page 3 of the club magazine. You need to register in the normal way
  • AOL Customers: Make sure you check the 'Remember me' check box otherwise the AOL system may log you out during the session. This is a known issue with AOL.
  • AOL, Yahoo and Plus.net users. Forum owners such as us are finding that AOL, Yahoo and Plus.net are blocking a lot of email generated from forums. This may mean your registration activation and other emails will not get to you, or they may appear in your spam mailbox

Thread Informations

D5 - no power when kick down

Views : 3188

Replies : 66

Users Viewing This Thread :  

Reply
 
Thread Tools Display Modes
Old Jan 25th, 2019, 13:31   #61
37 RUBY
Member
 
37 RUBY's Avatar
 

Last Online: Apr 14th, 2019 20:15
Join Date: Jun 2017
Location: Chesterfield
Default

Hello NorthantsPete

With such a robust yet complex machine I suspect your quest with additives mask the symptoms until all the additive has been burnt in the combustion chamber.

I doubt it is the fuel from either BP or Shell

There are a myriad of components that could cause your symptoms such as failing MAF (as you mentioned previously. Was that a new unit ?), sticking turbo vanes, failing crankshaft/lambda/coolant/inter cooler pressure sensors/failing low or high pressure fuel pumps/partially blocked fuel filter/blocked egr/wiring loom breaks/corroded connectors/worn injectors/tired inter cooler pipe bellowing out.....the list is endless.

You only need one component to throw a rogue signal and you suddenly get the reduction of power you are experiencing.

What you need is an expert who can read into the codes logged to locate the component(s) causing the issue.

If you are relying on one garage and have had no cure they are the wrong garage for you.

Perhaps there is someone on this forum near to you with Vida who can lend a hand.
__________________
2015 XC70 SE NAV LUX D5
37 RUBY is offline   Reply With Quote
The Following 2 Users Say Thank You to 37 RUBY For This Useful Post:
Old Jan 25th, 2019, 18:02   #62
37 RUBY
Member
 
37 RUBY's Avatar
 

Last Online: Apr 14th, 2019 20:15
Join Date: Jun 2017
Location: Chesterfield
Default From another post...

Quote:
Originally Posted by jamesmark View Post
Was actually on 27th December, but I treated her to Polestar upgrade.

Not had the benefit of it, as rarely drove her after and last week driving down to Bristol from S. Yorks she was loosing power badly.

So into Volvo where the Tmap sensor was faulty, so car was not boosting correctly. So that's all fixed and pick her back up this Saturday when I travel back.


Hopefully she is a new car now, as I did notice the odd loss of power before the P* upgrade but put it down to a lazy gearbox as only happened when I put foot down, and only about 2 times, but my drive down to Bristol it happened about 15 times, but now P* and Tmap done it should feel a lot better. Fingers crossed.
I was reading the above from this post https://www.volvoforums.org.uk/showt...12#post2488712

the highlighted text fits with what could be one of a variety issues your vehicle is having.
__________________
2015 XC70 SE NAV LUX D5
37 RUBY is offline   Reply With Quote
Old Mar 13th, 2019, 15:13   #63
NorthantsPete
Member
 
NorthantsPete's Avatar
 

Last Online: Mar 25th, 2019 15:06
Join Date: Mar 2015
Location: Northampton
Default

So, I found the issue.

With no diagnositics, I thought I either buy a Vida, 60 spent and find out the issue, maybe, and buy more parts or get it to a garage....

or live with it (tried until it happened every journey and shell V stopped working)

or take a punt on a part that I cleaned up, which made a very slight difference.


So, replaced the MAF and all is now fixed! The garage clearly just cleaned it before as they didnt specify they changed the maf, just said they 'did something'. I knew it on my 3rd post it felt like a maf issue as per my old V70 non-diesel, foot down and sputter/no power.

done about 900 miles so far so good.
__________________
2007 Mk3 V70 D5 2.4 Auto
*expired* 2000 Mk2 V70 2.4T SE Auto 135k
Northampton, UK

Last edited by NorthantsPete; Mar 13th, 2019 at 15:22.
NorthantsPete is offline   Reply With Quote
Old Mar 13th, 2019, 15:20   #64
NorthantsPete
Member
 
NorthantsPete's Avatar
 

Last Online: Mar 25th, 2019 15:06
Join Date: Mar 2015
Location: Northampton
Default

Quote:
Originally Posted by Fatskeleton View Post
once again when joining the bypass after putting fuel in, booted it and it went into limp mode. When I came to a stop 6 miles down the road I stopped the engine and restarted it, an it was fine and went like a rocket. is it an electrical fault?? I cant get my head round it. If it was mechanical wouldn't it be there all the time?
See my last post. Get one cheap off ebay, second hand (dont go chinese), and see if it improves.
__________________
2007 Mk3 V70 D5 2.4 Auto
*expired* 2000 Mk2 V70 2.4T SE Auto 135k
Northampton, UK
NorthantsPete is offline   Reply With Quote
Old Mar 13th, 2019, 21:21   #65
seanc
Junior Member
 

Last Online: Today 09:23
Join Date: May 2011
Location: Wyboston, Bedfordshire
Default

Quote:
Originally Posted by NorthantsPete View Post
So, I found the issue.

With no diagnositics, I thought I either buy a Vida, 60 spent and find out the issue, maybe, and buy more parts or get it to a garage....

or live with it (tried until it happened every journey and shell V stopped working)

or take a punt on a part that I cleaned up, which made a very slight difference.


So, replaced the MAF and all is now fixed! The garage clearly just cleaned it before as they didnt specify they changed the maf, just said they 'did something'. I knew it on my 3rd post it felt like a maf issue as per my old V70 non-diesel, foot down and sputter/no power.

done about 900 miles so far so good.
Glad to hear you've sorted it!
How many miles on the clock? Do you know what Volvo part number you used on the replacement?
__________________
2012 S80 D3 Geartronic
seanc is offline   Reply With Quote
Old Mar 13th, 2019, 21:43   #66
NorthantsPete
Member
 
NorthantsPete's Avatar
 

Last Online: Mar 25th, 2019 15:06
Join Date: Mar 2015
Location: Northampton
Default

133k

i took the model numbers off the top of the old one

hopefully others get it sorted too, many discount the maf but my second volvo and second maf!
__________________
2007 Mk3 V70 D5 2.4 Auto
*expired* 2000 Mk2 V70 2.4T SE Auto 135k
Northampton, UK
NorthantsPete is offline   Reply With Quote
Old Today, 22:09   #67
vcc
New Member
 

Last Online: Today 22:14
Join Date: Sep 2015
Location: Ljubljana
Default

Quote:
Originally Posted by NorthantsPete View Post
133k

i took the model numbers off the top of the old one

hopefully others get it sorted too, many discount the maf but my second volvo and second maf!
Can you please tell me where did you got your replacement sensor and what was the price? I have similar issues and this could be the solution.

Thanks!
vcc is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 23:24.


Powered by vBulletin
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.