Volvo Community Forum. The Forums of the Volvo Owners Club

Forum Rules Volvo Owners Club About VOC Volvo Gallery Links Volvo History Volvo Press
Go Back   Volvo Owners Club Forum > "Technical Topics" > 200 Series General > 200 Series Sales
Register Members CarsBlogs Help Calendar Mark Forums Read

Notices

Information
  • VOC Members: There is no login facility using your VOC membership number or the details from page 3 of the club magazine. You need to register in the normal way
  • AOL Customers: Make sure you check the 'Remember me' check box otherwise the AOL system may log you out during the session. This is a known issue with AOL.
  • AOL, Yahoo and Plus.net users. Forum owners such as us are finding that AOL, Yahoo and Plus.net are blocking a lot of email generated from forums. This may mean your registration activation and other emails will not get to you, or they may appear in your spam mailbox

Thread Informations

240 instrument cluster conundrum....

Views : 560

Replies : 2

Users Viewing This Thread :  

Reply
 
Thread Tools Display Modes
Old Jun 24th, 2018, 23:28   #1
mjohansson
New Member
 

Last Online: Jun 24th, 2018 23:29
Join Date: Jun 2018
Location: Cottage Grove
Default 240 instrument cluster conundrum....

Hello all I seem to have a serious problem with my old 1992 Volvo 240. First it all started with a NO instrument back lighting at all I had ordered new bulbs but found out the dealer ordered the wrong ones. So when I pulled out the cluster a job that I have done a dozen times on various 240's for some reason the "L" shaped connector broke off part of the circuit board on my speedometer cluster. I had a spare cluster out of a 90 240 so I swapped that. Speedometer did not work at all then. I noted on the top portion of my speedometer there are differences in the pin configuration. One has 3 pins the other has 4. So I did some soldering and swapping from the broken 4 pin to the ok 3 pin speedo. Now the car will not start. Like the fuel pump is not getting power. Major bummer. All the inst lights work, but the car will not start. So...I guess I have to find a replacement 4 pin small circuit board for my original speedo, correct? is there a place I can order one as the local junk yards no longer have any 240 Volvo's at all!
Thanks and God bless.
mjohansson is offline   Reply With Quote
Old Jun 25th, 2018, 11:49   #2
Derek UK
VOC Member
 
Derek UK's Avatar
 

Last Online: Today 13:58
Join Date: Jul 2006
Location: Chatham
Default

If swapping in another cluster you need one with the same type number Example K39200. Middle centre below the needle pivot. What is your number?
Derek UK is online now   Reply With Quote
Old Jul 25th, 2018, 19:28   #3
BrianH
VOC Member
 

Last Online: Yesterday 20:06
Join Date: Apr 2006
Location: Bournemouth
Blog Entries: 121
Default Instrument cluster and speedo

Ring Speedy Cables and talk to Ryan on 01639 732300.

He has sorted mine out several times. Knows his stuff

BrianH 1989 245 GL
BrianH is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 14:28.


Powered by vBulletin
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.