Volvo Community Forum. The Forums of the Volvo Owners Club

Forum Rules Volvo Owners Club About VOC Volvo Gallery Links Volvo History Volvo Press
Go Back   Volvo Owners Club Forum > "Technical Topics" > XC60 '17> / XC90 '14> / S90 & V90 '16> General
Register Members CarsBlogs Help Calendar Mark Forums Read

Notices

XC60 '17> / XC90 '14> / S90 & V90 '16> General Forum for all vehicles post 2014 based on Volvos new Scalable Platform Architecture or SPA

Information
  • VOC Members: There is no login facility using your VOC membership number or the details from page 3 of the club magazine. You need to register in the normal way
  • AOL Customers: Make sure you check the 'Remember me' check box otherwise the AOL system may log you out during the session. This is a known issue with AOL.
  • AOL, Yahoo and Plus.net users. Forum owners such as us are finding that AOL, Yahoo and Plus.net are blocking a lot of email generated from forums. This may mean your registration activation and other emails will not get to you, or they may appear in your spam mailbox

Thread Informations

V90 issues post 1st service.

Views : 574

Replies : 9

Users Viewing This Thread :  

Reply
 
Thread Tools Display Modes
Old Aug 19th, 2019, 16:56   #1
Berkshirebob
Junior Member
 

Last Online: Yesterday 16:36
Join Date: Sep 2018
Location: Newbury
Default V90 issues post 1st service.

Dear all

My V90 had its first service last Friday and as a result there are some good things, and some not so good things..

I reported the following:

Squeaky R/H steering wheel volume buttons - to be replaced. I need to go back when in stock.
Clicky drivers seat - greased so quiet now, but can still feel it.
Slow to fill Adblue - no fault found..
Rear centre armrest bit of plastic showing - they’re all like that sir..
Lacquer falling off 18’ wheels - pictures sent to HQ..

The service was £350.00 and they quoted me £196.00 (each) for front tyres. Just replaced at a local place for £114.00 each - same ‘VOL’ marked P Zero’s.

Software updated so I now have the Stop/Start picture instead of ‘Ready’ and what a result the update is!
S/S now doesn’t engage until the car is stationary and the gearbox is transformed. No more revving to infinity and seems to now work exactly as you would expect.

But driving from Newbury to Oxford earlier the speakers gave up with only the front tweeters working, all others were silent?! Then the TPMS went off.. Both issues were fixed whilst I was at my destination - ignition off for an hour. (Merc Oxford - drooping a friend off to collect his C63s)

No trouble on the way back, other than I couldn’t keep up with my mate in his new car!

Rob.
__________________
MY19 V90 D4 R Design. Osmium Grey
Berkshirebob is offline   Reply With Quote
Old Aug 19th, 2019, 20:22   #2
Zebra
Junior Member
 

Last Online: Today 06:57
Join Date: Jul 2010
Location: Melton Mowbray
Default

"Slow to fill Adblue"?
__________________
XC90 D5 Inscription Pro MY2019, Xenium, 22" Alloys, 19" winters, Smartphone Integration, BLIS + CTA & RCM, Tinted Windows, Bowers and Wilkins Sound.

V40 D2 R-Design Nav Plus MY2017, 18" wheels, winter pack.
Zebra is offline   Reply With Quote
Old Aug 19th, 2019, 21:01   #3
Berkshirebob
Junior Member
 

Last Online: Yesterday 16:36
Join Date: Sep 2018
Location: Newbury
Default

Quote:
Originally Posted by Zebra View Post
"Slow to fill Adblue"?
Half an hour to fill the tank with most of it getting spat out. I thought perhaps a blocked vent, but all ok apparently..

Might be the forecourt bottles that are the issue? First car I’ve had that’s needed it.
__________________
MY19 V90 D4 R Design. Osmium Grey
Berkshirebob is offline   Reply With Quote
Old Aug 20th, 2019, 08:22   #4
Zebra
Junior Member
 

Last Online: Today 06:57
Join Date: Jul 2010
Location: Melton Mowbray
Default

Ahh that makes sense.

I use Costco Adblue which seems to fill with the supplied spout fairly quickly. If I wait until it says no start in 1000 miles I can get two five litre containers in.
__________________
XC90 D5 Inscription Pro MY2019, Xenium, 22" Alloys, 19" winters, Smartphone Integration, BLIS + CTA & RCM, Tinted Windows, Bowers and Wilkins Sound.

V40 D2 R-Design Nav Plus MY2017, 18" wheels, winter pack.
Zebra is offline   Reply With Quote
The Following User Says Thank You to Zebra For This Useful Post:
Old Aug 20th, 2019, 15:31   #5
badonkadonk
New Member
 

Last Online: Today 13:25
Join Date: May 2019
Location: Glasgow
Default

I've found the same thing with adblue, using the big container from euro carparts, think it's just an airlock issue, first few litres took ages then it seemed to go a bit better. Got a bit of the adblue splashed back a few times, luckily it doesn't seem to be smelly, was worried that it might smell "nasty" with urea being the active ingredient.

What's the SS issue you've seen? My S90 does seem over-eager to stop the engine, and frequently shuts it down before the car is fully stopped.
__________________
Volvo S90 D5 R-Design
badonkadonk is online now   Reply With Quote
Old Aug 20th, 2019, 15:42   #6
Berkshirebob
Junior Member
 

Last Online: Yesterday 16:36
Join Date: Sep 2018
Location: Newbury
Default

Quote:
Originally Posted by badonkadonk View Post

What's the SS issue you've seen? My S90 does seem over-eager to stop the engine, and frequently shuts it down before the car is fully stopped.
Hi. Exactly that - shuts down while you’re still rolling, only to restart immediately. Post service/software update (with the new icon) it stops after you are stationary for a second or two.
__________________
MY19 V90 D4 R Design. Osmium Grey
Berkshirebob is offline   Reply With Quote
Old Aug 20th, 2019, 15:57   #7
AdamP
New Member
 

Last Online: Sep 10th, 2019 22:03
Join Date: Oct 2008
Location: Newbury
Default

Quote:
Originally Posted by badonkadonk View Post
Got a bit of the adblue splashed back a few times, luckily it doesn't seem to be smelly, was worried that it might smell "nasty" with urea being the active ingredient.
Urea is odourless as you found, ammonia is the smelly stuff.
AdamP is offline   Reply With Quote
Old Aug 20th, 2019, 17:36   #8
AB-UK
Premier Member
 

Last Online: Today 09:32
Join Date: Jul 2007
Location: Nottingham
Default

Quote:
Originally Posted by Berkshirebob View Post
The service was £350.00 and they quoted me £196.00 (each) for front tyres. Just replaced at a local place for £114.00 each - same ‘VOL’ marked P Zero’s.
How many miles did the tyres last?
AB-UK is offline   Reply With Quote
Old Aug 20th, 2019, 19:16   #9
Berkshirebob
Junior Member
 

Last Online: Yesterday 16:36
Join Date: Sep 2018
Location: Newbury
Default

Quote:
Originally Posted by AB-UK View Post
How many miles did the tyres last?
18146 just above the wear- markers. I do possibly drive it harder than most.. But mostly motorway miles.
__________________
MY19 V90 D4 R Design. Osmium Grey
Berkshirebob is offline   Reply With Quote
Old Aug 21st, 2019, 09:08   #10
badonkadonk
New Member
 

Last Online: Today 13:25
Join Date: May 2019
Location: Glasgow
Default

Quote:
Originally Posted by Berkshirebob View Post
Hi. Exactly that - shuts down while you’re still rolling, only to restart immediately. Post service/software update (with the new icon) it stops after you are stationary for a second or two.
Great. I look forward to this update on my next service then. This behaviour of SS is really annoying!
__________________
Volvo S90 D5 R-Design
badonkadonk is online now   Reply With Quote
The Following User Says Thank You to badonkadonk For This Useful Post:
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 14:19.


Powered by vBulletin
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.