Volvo Community Forum. The Forums of the Volvo Owners Club

Forum Rules Volvo Owners Club About VOC Volvo Gallery Links Volvo History Volvo Press
Go Back   Volvo Owners Club Forum > "Technical Topics" > S80 '98-'06 / S60 '00-'09 / V70 & XC70 '00-'07 General > S80 '98-'06 / S60 '00-'09 / V70 & XC70 '00-'07 Articles

Notices

Information
  • VOC Members: There is no login facility using your VOC membership number or the details from page 3 of the club magazine. You need to register in the normal way
  • AOL Customers: Make sure you check the 'Remember me' check box otherwise the AOL system may log you out during the session. This is a known issue with AOL.
  • AOL, Yahoo and Plus.net users. Forum owners such as us are finding that AOL, Yahoo and Plus.net are blocking a lot of email generated from forums. This may mean your registration activation and other emails will not get to you, or they may appear in your spam mailbox

Thread Informations

How to fix idling problems, petrol engined S80

Views : 33212

Replies : 32

Users Viewing This Thread :  

 
 
Thread Tools Display Modes
Old Nov 8th, 2007, 11:11   #21
jtaw45
Senior Member
 

Last Online: May 20th, 2022 15:01
Join Date: Dec 2004
Location: Hull
Default

Right,Hopefully problem now solved.The car continued showing the emision lamp and would run like a tractor,this got even worse till driveability was virtually zero.The car was very,very slow from a standing start but slightly better once momentum was gained,it would barely tickover at all.I've replaced BOTH front lambda sensors and the car is running as normal again.I'll clear the codes at the weekend if the lamps still on,when i replaced the MAF the light went out of it's own accord after about 40 miles.If i need to clear the codes whats the best method.Will disconnecting the battery bring the airbag light on or will it be ok,do i need to disconnect both leads or just the neg or pos?
jtaw45 is offline  
Old Nov 8th, 2007, 11:17   #22
niloc
SWV Benefactor
 
niloc's Avatar
 

Last Online: Jan 30th, 2013 14:44
Join Date: Dec 2001
Location: Newport, South Wales
Default

I think there is a proper procedure for disconnecting the battery - having the key in a certain position for disconnection, and i think a different one for reconnection.
__________________
Refitting is the reverse of removal???.....Yeah, right!
niloc is offline  
Old Nov 9th, 2007, 12:22   #23
jtaw45
Senior Member
 

Last Online: May 20th, 2022 15:01
Join Date: Dec 2004
Location: Hull
Default

Can anyone offer any advice on clearing the codes.I'm worried by disconnecting the battery that the airbag light will come on,am i worrying unjustly?
jtaw45 is offline  
Old Nov 10th, 2007, 17:13   #24
Oscar the Dachshund
New Member
 
Oscar the Dachshund's Avatar
 

Last Online: Apr 21st, 2013 15:12
Join Date: Aug 2007
Location: Glasgow
Default Code Clearing

I've disconnected the battery on my S80 a couple of times, no problems.
Disconnect it, put your foot on the footbrake for a minute, then reconnect the battery, don't touch any pedals, start the engine and allow to idle for a couple of minutes without touching the gas. Should be okay,
__________________
OSCAR
VOLVO S80 2.4
Oscar the Dachshund is offline  
Old Nov 10th, 2007, 17:23   #25
Clan
Experienced Member
 
Clan's Avatar
 

Last Online: Yesterday 22:10
Join Date: Jun 2007
Location: L/H side
Default

they are very reliable normaly . not a great call for them. Same goes for Catalytic converters and exhaust systems ...
__________________
My comments are only based on my opinions and vast experience .
Clan is offline  
Old Nov 19th, 2007, 14:40   #26
jtaw45
Senior Member
 

Last Online: May 20th, 2022 15:01
Join Date: Dec 2004
Location: Hull
Default

My problems are now solved.I replaced both front sensors and after a week the emmision lamp has gone out.Job done.
jtaw45 is offline  
Old Nov 19th, 2007, 22:14   #27
MATHIUS
Volvo for life . . .
 
MATHIUS's Avatar
 

Last Online: Yesterday 08:16
Join Date: Nov 2000
Location: Lapford, Devon
Default Etm

Hi guys,

Followed the instructions on how to clean the ETM, Did everything by the book. Took the car for a quick spin and everything is ok! Except when i switched it off and then restarted it, The Engine light has come on and won't go off ! ! ! !
My etm was really gunky and black, Just by cleaning it has made a huge difference.

Matt.
MATHIUS is offline  
The Following User Says Thank You to MATHIUS For This Useful Post:
Old Feb 20th, 2008, 09:11   #28
top daddy
New Member
 

Last Online: Feb 20th, 2008 09:15
Join Date: Feb 2008
Location: rotherham
Default thank you

being having trouble starting car & with cutting out since being under warranty tried cleaning out throttle housing as suggested & car started first time this morning without any smoke thanks a lot
top daddy is offline  
Old Sep 27th, 2010, 21:18   #29
jjmenei
New Member
 

Last Online: Nov 3rd, 2011 02:52
Join Date: Nov 2009
Location: Carlsbad, Ca
Default

Hi Oscar,
Question, what could be causing my engine surge?
My 2000 V70 SE station wagon 2.5L Non-turbo is experiencing a slight engine surge when traveling approximately 68 MPH. I also notice (at low speeds less than 20 MPH) a low base sound while accelerating from a stop sign and when the car shifts to second the base noise disappears until the throttle is activated again.
Do you think this base noise is related to the engine surging?
This past weekend I replaced my Fuel Filter & Gas Cap & the surging is still present.
Any suggestions would be greatly appreciated. Jim M
jjmenei is offline  
Old Oct 17th, 2010, 22:27   #30
MikeS60D5
Junior Member
 
MikeS60D5's Avatar
 

Last Online: Sep 12th, 2011 16:04
Join Date: Oct 2009
Location: Liverpool
Default

on a few occasions, my engine has cut out, mine is a T5.
i was going to try this remady but obv with mine being a turbo it's different.

Any recomendations??


Cheer's
Mike
MikeS60D5 is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 04:04.


Powered by vBulletin
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.