Volvo Community Forum. The Forums of the Volvo Owners Club

Forum Rules Volvo Owners Club About VOC Volvo Gallery Links Volvo History Volvo Press
Go Back   Volvo Owners Club Forum > "Technical Topics" > S80 '06> / V70 '07> / XC70 '07> General
Register Members CarsBlogs Help Calendar Mark Forums Read

Notices

S80 '06> / V70 '07> / XC70 '07> General Forum for the Volvo S80 '06> / V70 '07> XC70 '07> models (V70 Generation 3)

Information
  • VOC Members: There is no login facility using your VOC membership number or the details from page 3 of the club magazine. You need to register in the normal way
  • AOL Customers: Make sure you check the 'Remember me' check box otherwise the AOL system may log you out during the session. This is a known issue with AOL.
  • AOL, Yahoo and Plus.net users. Forum owners such as us are finding that AOL, Yahoo and Plus.net are blocking a lot of email generated from forums. This may mean your registration activation and other emails will not get to you, or they may appear in your spam mailbox

Thread Informations

Tg-81sc no comms - 2015 v70

Views : 260

Replies : 3

Users Viewing This Thread :  

Reply
 
Thread Tools Display Modes
Old Mar 14th, 2019, 19:01   #1
ymc30
Member
 
ymc30's Avatar
 

Last Online: Aug 17th, 2019 08:51
Join Date: Nov 2013
Location: London
Default Tg-81sc no comms - 2015 v70

Hi guys I desperately need your help as I am running out of ideas

Foreplay:
I've bought a 65 plate V70 D4 with a failed engine (D4204T5) which is an 8 speed auto (TG-81SC). I also happened to have a working engine-gearbox from an accident damaged V70 - same engine/gearbox combo.

Last week I dropped the failed engine with the gearbox and put the working one in. I did NOT touch any modules I even failed to change over the TCM from the non working engine/gearbox unit (where the gearbox is supposedly was working)

The car started first time and was running OK although next day I had "reduced transmission performance" but after I cleared the DTCs it went away and the gearbox was working fine but I still had some TCM related faults but hey, who cares?!?


The fun bit:
Today I took the TCM from the failed engine/gearbox combo (which TCM belongs to the car originally) to get rid of the DTCs.

Disconnected the battery, changed the TCM, reconnected everything - since then the car could not see the gear position (Shift gear to P) and refuse to start.

No connection with TCM and strangely no comms with power steering. Also no gear selection symbol on the RH side of the speedo.
Please see DTCs attached.

Any help would be appreciated
Attached Images
File Type: png Volvo V70 2015 no comms.PNG (36.1 KB, 9 views)
__________________
You've got grease on your fingers / Oil on your face / Happy completely chasing the pace [Chris Rea]

C30 SE Lux 2.0D / C30 1.6D Drive / Miata NCFL 2.0 Sport Tec
Sold: C70 T5 / C30 1.8 SE Lux / C30 1.6 R-Design / V50 D4 Geartronic

Last edited by ymc30; Mar 14th, 2019 at 19:06. Reason: typo
ymc30 is offline   Reply With Quote
Old Mar 15th, 2019, 05:42   #2
KBB
Master Tech
 

Last Online: Jun 22nd, 2019 10:38
Join Date: Dec 2006
Location: On Contract Dubai Automotve Technical Academy
Default

If scan tool is showing no comm with sub modules the I would be checking powers and grounds to those modules.

If you have been removing and replacing engine and transmission then there may be a missing ground.
KBB is offline   Reply With Quote
Old Mar 15th, 2019, 09:26   #3
ymc30
Member
 
ymc30's Avatar
 

Last Online: Aug 17th, 2019 08:51
Join Date: Nov 2013
Location: London
Default

Quote:
Originally Posted by KBB View Post
If scan tool is showing no comm with sub modules the I would be checking powers and grounds to those modules.

If you have been removing and replacing engine and transmission then there may be a missing ground.
Thanks for the reply.

I swapped everything by lowering the subframe and followed it up in Vida.
Car was running after the swap OK although with fault codes (supposedly because the TCM was from the other car) So everything was connected properly.

This problem occurred after the swap of the TCM which seemed to be an easy process. Battery disconnected, a few bolts taken out, swapped the module (made sure it is properly seated), job done. NOT

Since then I checked the fusees for the TCM (all good), swapped back the other module, no joy.

I am thinking more along the lines not waiting long enough before taking the TCM out after the battery disconnected so something burnt out?!

Symptoms are:
- no connection to TCM
- strangely no connection to PSM (maybe a telltale for someone)
- Park position is not recognised - not shown on the right side of the speedometer (probably due to no comms with TCM)
Attached Images
File Type: jpg subframe.jpg (341.0 KB, 18 views)
__________________
You've got grease on your fingers / Oil on your face / Happy completely chasing the pace [Chris Rea]

C30 SE Lux 2.0D / C30 1.6D Drive / Miata NCFL 2.0 Sport Tec
Sold: C70 T5 / C30 1.8 SE Lux / C30 1.6 R-Design / V50 D4 Geartronic
ymc30 is offline   Reply With Quote
Old Mar 21st, 2019, 09:56   #4
ymc30
Member
 
ymc30's Avatar
 

Last Online: Aug 17th, 2019 08:51
Join Date: Nov 2013
Location: London
Default Solved

Just a quick follow up for anybody interested...

After having half of the car taken apart I gave up. Next day put the whole thing together and the problem was gone.

The Start-stop system has some fuses in the "engine compartment cold zone" which is really - I mean really - hard to reach hence the reason the car was in pieces. This meant that the supply battery was also disconnected overnight alongside with the main one. I don't know whether this done the trick?!?

Also first I connected everything up except the TCM which wasn't even plugged in to the gearbox. Obviously engine did not start.
Next up I connected the TCM to the wiring loom but not to the gearbox. This resulted a bunch of DTCs related to gearbox pressure sensors, etc. Engine refused to start obviously.
Finally everything properly connected - engine started first time. Still has some TCM related DTCs but I'll figure them out later.
__________________
You've got grease on your fingers / Oil on your face / Happy completely chasing the pace [Chris Rea]

C30 SE Lux 2.0D / C30 1.6D Drive / Miata NCFL 2.0 Sport Tec
Sold: C70 T5 / C30 1.8 SE Lux / C30 1.6 R-Design / V50 D4 Geartronic
ymc30 is offline   Reply With Quote
Reply

Tags
no comms, tg-81sc


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 14:20.


Powered by vBulletin
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.