Volvo Community Forum. The Forums of the Volvo Owners Club

Forum Rules Volvo Owners Club About VOC Volvo Gallery Links Volvo History Volvo Press
Go Back   Volvo Owners Club Forum > "Technical Topics" > S60 '10> / V60 '11> / XC60 '08>'17 General
Register Members CarsBlogs Help Calendar Mark Forums Read

Notices

S60 '10> / V60 '11> / XC60 '08>'17 General Forum for the Volvo x60 Series of cars

Information
  • VOC Members: There is no login facility using your VOC membership number or the details from page 3 of the club magazine. You need to register in the normal way
  • AOL Customers: Make sure you check the 'Remember me' check box otherwise the AOL system may log you out during the session. This is a known issue with AOL.
  • AOL, Yahoo and Plus.net users. Forum owners such as us are finding that AOL, Yahoo and Plus.net are blocking a lot of email generated from forums. This may mean your registration activation and other emails will not get to you, or they may appear in your spam mailbox

Thread Informations

XC60 2.4 D4 AWD weird engine noise

Views : 312

Replies : 4

Users Viewing This Thread :  

Reply
 
Thread Tools Display Modes
Old Nov 22nd, 2019, 22:49   #1
Sevsevbar
New Member
 

Last Online: Nov 23rd, 2019 19:23
Join Date: Nov 2019
Location: Barnsley
Default XC60 2.4 D4 AWD weird engine noise

Hi Guys 👋

My first post in here, so please be nice!

Iíve had a search through here and the diesel engine threads, but canít find anything like what Iím looking for.

Long story short, my 2015 XC60 with 2.4 D4 engine is making a weird noise while under load/heavy acceleration.. but only in 4th gear upwards, and only between about 1300 and 2000 rpm.

The noise starts out as you hear the turbo start to spool at about 1300rpm or so (you can hear the high pitched spin of the turbo starting) and then a whiney/squeely/almost-rattly-but-not noise overpowers this up until about 2000 rpm when the noise dies away to nothing and the sound of the V5 and turbo dominate (much to my amusement..).. also, as the turbo obviously doesnít kick in properly until about the time this noise stops, the car does vibrate the smallest amount (being a diesel, I attribute the vibration to just that, as tractor engines are known to chug arenít they!) so I donít know if itís just a really rapid rattle..?

Equally, if I accelerate steadily the noise isnít there.. you can still hear the turbo wanting to spool up, but no other high pitched noises.

Itís almost a similar noise to what you get in an older car on start up, when a belt is slipping and you get that squeal as the car is revíd for a little while.

What is throwing me off is that I havenít heard this noise in 3rd gear or below.. only 4th and above (maybe because the revs jump up to 2000 rpm so much quicker??).

Could be a belt thatís lost itís proper tension? But would it stop making noise above a certain rpm of that was the case, and would it only be in higher gears?

Iíd offer turbo bearings as a possibility, but again, itís only in higher gears (longer spool time because of bigger gears higher up gear box so issue/sound becomes prevalent maybe?).. and as said, if taking it steady you can still hear the turbo wanting to spool up, and if you boot it above 2000 rpm thereís no nasty noise, just boost and engine noise!

Not had chance to check all fluid levels yet incase something is running low so canít rule that out.. but does anyone have similar past experience? If so, what was involved!

Car doesnít feel lumpy, plenty of power, no warning lights, no codes etc.. just a really annoying noise!

Thanks in advance guys.. and sorry for the really long bedtime story Iíve just written

Last edited by Sevsevbar; Nov 22nd, 2019 at 23:02.
Sevsevbar is offline   Reply With Quote
Old Nov 23rd, 2019, 14:01   #2
The Thong
VOC Member
 
The Thong's Avatar
 

Last Online: Yesterday 22:28
Join Date: Jun 2012
Location: The Independent Republic of Leamington Spa
Default

How many miles has it done?
__________________
Who allowed this to happen??
The Thong is offline   Reply With Quote
Old Nov 23rd, 2019, 14:16   #3
Clan
Experienced Member
 
Clan's Avatar
 

Last Online: Yesterday 23:33
Join Date: Jun 2007
Location: L/H side
Default

Quote:
Originally Posted by Sevsevbar View Post
Hi Guys 👋

My first post in here, so please be nice!

Iíve had a search through here and the diesel engine threads, but canít find anything like what Iím looking for.

Long story short, my 2015 XC60 with 2.4 D4 engine is making a weird noise while under load/heavy acceleration.. but only in 4th gear upwards, and only between about 1300 and 2000 rpm.

The noise starts out as you hear the turbo start to spool at about 1300rpm or so (you can hear the high pitched spin of the turbo starting) and then a whiney/squeely/almost-rattly-but-not noise overpowers this up until about 2000 rpm when the noise dies away to nothing and the sound of the V5 and turbo dominate (much to my amusement..).. also, as the turbo obviously doesnít kick in properly until about the time this noise stops, the car does vibrate the smallest amount (being a diesel, I attribute the vibration to just that, as tractor engines are known to chug arenít they!) so I donít know if itís just a really rapid rattle..?

Equally, if I accelerate steadily the noise isnít there.. you can still hear the turbo wanting to spool up, but no other high pitched noises.

Itís almost a similar noise to what you get in an older car on start up, when a belt is slipping and you get that squeal as the car is revíd for a little while.

What is throwing me off is that I havenít heard this noise in 3rd gear or below.. only 4th and above (maybe because the revs jump up to 2000 rpm so much quicker??).

Could be a belt thatís lost itís proper tension? But would it stop making noise above a certain rpm of that was the case, and would it only be in higher gears?

Iíd offer turbo bearings as a possibility, but again, itís only in higher gears (longer spool time because of bigger gears higher up gear box so issue/sound becomes prevalent maybe?).. and as said, if taking it steady you can still hear the turbo wanting to spool up, and if you boot it above 2000 rpm thereís no nasty noise, just boost and engine noise!

Not had chance to check all fluid levels yet incase something is running low so canít rule that out.. but does anyone have similar past experience? If so, what was involved!

Car doesnít feel lumpy, plenty of power, no warning lights, no codes etc.. just a really annoying noise!

Thanks in advance guys.. and sorry for the really long bedtime story Iíve just written
Have you got two turbochargers ?
__________________
My comments are only based on my opinions and vast experience .
Clan is online now   Reply With Quote
Old Nov 23rd, 2019, 18:24   #4
Sevsevbar
New Member
 

Last Online: Nov 23rd, 2019 19:23
Join Date: Nov 2019
Location: Barnsley
Default

Quote:
Originally Posted by The Thong View Post
How many miles has it done?
Just over 60k miles on the clock.



Quote:
Originally Posted by Clan View Post
Have you got two turbochargers ?
No, itís the D4, so just a single turbocharger.

Edit: I may stand corrected.. Iím hearing contradictory info on whether itís twin turbo or single (as itís the AWD).. I was sure it was single, as I thought the D5 was twin.. but Iím guna have to look under the bonnet tomorrow!



Iím feeling more and more that itís something to do with the turbo.. whether that be something thatís come loose, or a gasket at a joint (eg. manifold) thatís going/gone.. or worse. Or does anyone know if the EGR valve only opens between certain rev ranges? Perhaps a sticky EGR if thatís the case?

Hundred and one things it could be though I guess..

Last edited by Sevsevbar; Nov 23rd, 2019 at 19:23.
Sevsevbar is offline   Reply With Quote
Old Nov 23rd, 2019, 19:14   #5
The Thong
VOC Member
 
The Thong's Avatar
 

Last Online: Yesterday 22:28
Join Date: Jun 2012
Location: The Independent Republic of Leamington Spa
Default

Iím thinking along the lines of a gummed up PCV that make a whistling sound. Iíd be popping it into Volvo personally
__________________
Who allowed this to happen??
The Thong is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 00:22.


Powered by vBulletin
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.