Volvo Community Forum. The Forums of the Volvo Owners Club

Forum Rules Volvo Owners Club About VOC Volvo Gallery Links Volvo History Volvo Press
Go Back   Volvo Owners Club Forum > "Technical Topics" > AWD Discussion

Notices

AWD Discussion A forum dedicated to the AWD systems fitted to Volvo cars.

Information
  • VOC Members: There is no login facility using your VOC membership number or the details from page 3 of the club magazine. You need to register in the normal way
  • AOL Customers: Make sure you check the 'Remember me' check box otherwise the AOL system may log you out during the session. This is a known issue with AOL.
  • AOL, Yahoo and Plus.net users. Forum owners such as us are finding that AOL, Yahoo and Plus.net are blocking a lot of email generated from forums. This may mean your registration activation and other emails will not get to you, or they may appear in your spam mailbox

Thread Informations

Rear axle sensor XC70 2011

Views : 4887

Replies : 5

Users Viewing This Thread :  

Reply
 
Thread Tools Display Modes
Old Nov 18th, 2019, 15:04   #1
Priory
New Member
 

Last Online: Feb 11th, 2024 23:58
Join Date: Jul 2018
Location: Rossendale
Default Rear axle sensor XC70 2011

I have scoured the forums and google and can't seem to find an answer.
Volvo XC70 D5 2011 AWD auto.
B104421 rear axle sensor, general signal failure, signal too low.
040086 invalid data received Bus signal message failure signal invalid

I have owned it now for 18 months and the headlight failure message ( bending lights) has been on for 12 months, I need the part no and location please.
Thanks for any help.
Paul
Priory is offline   Reply With Quote
Old Nov 21st, 2019, 17:22   #2
100K+
Premier Member
 

Last Online: Yesterday 09:50
Join Date: Aug 2008
Location: Newcastle
Default

As no one has replied, I'll give you an alternative thought that might be totally off base, if so, sorry.
You say you have a headlight issue, I had a issue on a P2 V70 2004AWD. The issue was the rear level sensor. Unless the "rear axle sensor" is only on P3 AWD I believe we could be talking the same thing.

Attached are two pics to help you locate the "sensor" I replaced.
You may have two sensors as the AWD R V70/S60 had or only one - as the other models in the v70 P2 range had.
Both images are looking towards the front of the car.

Good luck
Cheers
Bob
Attached Images
File Type: jpg Position sensor 01.jpg (142.9 KB, 85 views)
File Type: jpg Position sensor 02.jpg (233.9 KB, 89 views)
100K+ is offline   Reply With Quote
Old Nov 30th, 2019, 16:01   #3
Priory
New Member
 

Last Online: Feb 11th, 2024 23:58
Join Date: Jul 2018
Location: Rossendale
Default

Thanks Bob
Just had it serviced and had occasion to look underneath, your 2nd pic looks like the sensor on the rear axle so we are going to try replacing it and see what happens,
Regards,
Paul
Priory is offline   Reply With Quote
Old Dec 1st, 2019, 13:20   #4
100K+
Premier Member
 

Last Online: Yesterday 09:50
Join Date: Aug 2008
Location: Newcastle
Default

Quote:
Originally Posted by Priory View Post
Thanks Bob
Just had it serviced and had occasion to look underneath, your 2nd pic looks like the sensor on the rear axle so we are going to try replacing it and see what happens,
Regards,
Paul
Hi Paul,
Good luck with the repair, but I would not be more than 20% surprised, if having replaced the sensor, the fault code needs to be removed from "storage" to get the lights/messages back to normal. It could clear itself and all be ok, but usually, once error codes are reported/stored they have to be read/cleared to "fix" the problem.

Cheers
Bob
100K+ is offline   Reply With Quote
Old Aug 27th, 2023, 10:54   #5
kizer
New Member
 

Last Online: Aug 28th, 2023 08:30
Join Date: Feb 2017
Location: Stoke-on-Trent
Default

Quote:
Originally Posted by Priory View Post
Thanks Bob
Just had it serviced and had occasion to look underneath, your 2nd pic looks like the sensor on the rear axle so we are going to try replacing it and see what happens,
Regards,
Paul
I have bendy lights on my 2011 xc70 and a warning light has been on for over three years, Last year I had it serviced by Volvo and they said the rear sensor wanted replacing, Now i've had it serviced this year now they have told me the front and rear sensor want replacing with a quote of nearly 600.00

Looks like I'm going to replace them my self I don't know how much the sensors cost its got to be cheaper than 600.
kizer is offline   Reply With Quote
Old Aug 28th, 2023, 08:30   #6
kizer
New Member
 

Last Online: Aug 28th, 2023 08:30
Join Date: Feb 2017
Location: Stoke-on-Trent
Default

Quote:
Originally Posted by Priory View Post
I have scoured the forums and google and can't seem to find an answer.
Volvo XC70 D5 2011 AWD auto.
B104421 rear axle sensor, general signal failure, signal too low.
040086 invalid data received Bus signal message failure signal invalid

I have owned it now for 18 months and the headlight failure message ( bending lights) has been on for 12 months, I need the part no and location please.
Thanks for any help.
Paul
The part number will be on the sensor or you can phone your local Volvo dealer parts department and they will give you the part number and order it for you, You could look for a third party manufacturer that might be cheaper, with my experience with these sensors your better getting the Volvo dealer part then you know it will work, all so this back sensor talks to the front sensor to work properly so if you do change the rear sensor and theres a problem with the front sensor you will still get a warning light on.
kizer is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 12:22.


Powered by vBulletin
Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.