Volvo Community Forum. The Forums of the Volvo Owners Club

Forum Rules Volvo Owners Club About VOC Volvo Gallery Links Volvo History Volvo Press
Go Back   Volvo Owners Club Forum > "Technical Topics" > XC90 '02'15 General

Notices

XC90 '02'15 General Forum for the Volvo XC90 Phase 1 Series

Information
  • VOC Members: There is no login facility using your VOC membership number or the details from page 3 of the club magazine. You need to register in the normal way
  • AOL Customers: Make sure you check the 'Remember me' check box otherwise the AOL system may log you out during the session. This is a known issue with AOL.
  • AOL, Yahoo and Plus.net users. Forum owners such as us are finding that AOL, Yahoo and Plus.net are blocking a lot of email generated from forums. This may mean your registration activation and other emails will not get to you, or they may appear in your spam mailbox

Thread Informations

DIM problems

Views : 123

Replies : 1

Users Viewing This Thread :  

Reply
 
Thread Tools Display Modes
Old Sep 17th, 2020, 18:21   #1
JohnL
Senior Member
 

Last Online: Yesterday 17:11
Join Date: Dec 2003
Location: Oise
Default DIM problems

The instrument cluster doesn't show any life, was working yesterday morning, but in the afternoon with key on there are no dials or lights. Engine runs and drives ok.
Read the codes in Vida,
DIM-E001 Control module faulty communication
DIM-E003 Configuration fault
SRS-00D5 Lamp fault

Cleared the codes, first drive seemed to be ok, but about a mile in, the mileage trips stopped reading then the fuel and temp gauges and then speed and rpm stopped, reread codes and the same.
Is this a dry joint in the DIM perhaps, all other items seem to working, indicators, lights, car runs and drives ok.
The DIM has been repaired by Volvo Diagnostics in London before and has worked fine since then.
The SRS lamp did light before everything went black.
Is there something I can check, as it will be a long shot to send it back to Diagnostics to fix.
John
JohnL is offline   Reply With Quote
Old Sep 17th, 2020, 19:21   #2
cheshired5
Premier Member
 

Last Online: Yesterday 15:31
Join Date: Dec 2013
Location: Crewe
Default

The only common possibility is CAN wiring so check everything between the DIM and the CEM.
Maybe pull the CEM to check for corrosion too.
__________________
2002 S60 SE D5 Manual
205000 miles
cheshired5 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 02:06.


Powered by vBulletin
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.